User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: brake light help needed

  1. #1
    Regular Member chrisg's Avatar
    Join Date
    Nov 2010
    Location
    hull
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default brake light help needed

    hi,
    When i turn my lights on i can hear a buzzing for the back left of the car but it goes when i press the brake. I dont have any warnings on the dash.
    Thanks for any help

  2. #2
    Regular Member ChrisBilly's Avatar
    Join Date
    Jul 2009
    Location
    The Rift, Cardiff
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check the fuses and earth points in the boot for both light clusters to make sure there's a good connection.

  3. #3
    Regular Member Wolfie01's Avatar
    Join Date
    Nov 2010
    Location
    Wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Got exactly the same problem, any ideas on a fix please?

  4. #4
    Regular Member Wolfie01's Avatar
    Join Date
    Nov 2010
    Location
    Wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    To be exact the buzzing is coming from one of two black boxes located in the boot fuse compartment. It only buzzes when the lights are on, and stops when you press the brake pedal, i've checked all the bulbs etc and all are fine.

  5. #5
    Regular Member Whisky's Avatar
    Join Date
    Mar 2011
    Location
    Kirkcaldy/Barrow-in-Furness
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like a loose wire in the plug, causing little arcs,give your brake light wire a wiggle without using the brakes,see if it stops, if it does then just re-solder.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brake Warning light and display error message , BUT BRAKE LIGHTS ARE WORKING FINE
    By JACKALG1 in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 24th May 2013, 18:56
  2. Brake Upgrade What's Needed
    By sunbeam250bhp in forum Handling & Braking
    Replies: 10
    Last Post: 27th March 2009, 23:22
  3. Spanner light & 3rd brake light warning?
    By simp_2.2sri in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 5th December 2008, 17:32
  4. Brake help needed
    By frazejax in forum Suspension, Wheels & Brakes
    Replies: 6
    Last Post: 14th July 2008, 23:39

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •