User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: vectra 2.2 dti owners and vari vane turbo

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default vectra 2.2 dti owners and vari vane turbo

    my vectra 2.2 dti drives ok but when it hits 3000 revs it struggles to go through the rev range, getting to 4000 revs can take nearly 10 seconds from 3000 revs on, im sure this is not normal
    also the car picks up ok prior to this but at no time do i get a hit from the turbo, being vari vane turbos should i feel it kicking in higher up the rev range
    myn is the vec b but i assume they have the same tuebo and engine

  2. #2
    Regular Member Graham's Avatar
    Join Date
    Sep 2005
    Location
    Macclesfield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Same engine and turbo. Yes should pull effortlessly all the way to the red line.

    Suspect you have a hole in your turbo pipes somewhere. This is a common prob on these engines.

    Do a search for turbo boost hoses.

  3. #3
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    - You should definately feel it when the turbo kicks in

    As graham suggested check your boost pipes aren't split, might also be worth checking the boost sensor and egr aren't clogged up

  4. #4
    Regular Member
    Join Date
    Feb 2009
    Location
    midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    egr i have cleaned as well as the boost sensor, i have a front mount intercooler and the pipes going to the inlet are alloy and samco which i know are fine, the pipe coming of the turbo is metal, so the only pipe remaining is the final rubber hose to intercooler and im sure its fine but will have a look
    also if there was a hole wouldnt the car produce black smoke from the exhaust and maybe engine management light

  5. #5
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    If there was a hole in the intercooler hose the car would produce massive amount of black smoke and eventually kick into limp mode(management light). When was it last serviced? Give the mass air flow sensor a squirt of brake cleaner...worked wonders on my old 3.0. It then worked just enough so I could diagnose it was faulty. Give it a try

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    car is serviced regularly every 3k with diesel oil and air filters.the air flow meter isnt even a year old, wouldnt putting carb cleaner on it damage it
    there are also no management lights coming on

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    normally gives me 34 mpg in the city and 50 mpg motorway only gave me 27 mpg todays in the city, all ihave done is vent the cranck fumes to atmosphere, surley this wouldnt cause problems to mpg
    other possibility is air flow meter but i have no engine management light coming on
    Last edited by turbo diesel; 17th December 2010 at 01:24.

  8. #8
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thought it was only the CDTI's that have variable-vane turbos.

  9. #9
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    Nope the 2.2dti has them too, the 2.0 doesn't though

  10. #10
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by john.robertson2 View Post
    Nope the 2.2dti has them too, the 2.0 doesn't though
    Thanks John. I knew the 2.0DTI didn't, just thought the 2.2 didn't either.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.0 turbo owners..
    By Steven in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 19th March 2012, 21:25
  2. All 2.0 turbo owners
    By pipamish in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 7th September 2011, 22:17
  3. vectra 2.2 dti owners and vari vane turbo
    By turbo diesel in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 15th December 2010, 14:41
  4. Vectra SRI Turbo Owners?
    By ropa83 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 4th September 2009, 19:32
  5. 2.0 Turbo owners ONLY!!
    By The-Bandit in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 7th January 2008, 22:15

Visitors found this page by searching for:

turbo boost 2.2dti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •