User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Z19dth thermostat

  1. #1
    Regular Member
    Join Date
    Sep 2010
    Location
    Netherlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question Z19dth thermostat

    Hello,

    Today my service light is coming up and my car switch to emergency modus.
    I checked with opcom the warnings and i don't see any strange things (i don't switch the contact to off).
    So i switch the contact off without resetting the faults and back on.
    The service light was coming up and going off and the car runs normal?

    Very strange... Because i don't see a warning with opcom?

    But what i see i came back from work and i see the temperature was going to 60g/celcuis. After a while it going back to zero and the service light was coming up.
    At home i started the car again and drive +- 1 km and the temperature is going to a normal level (in some seconds).

    So my question, i think i have a problem with my thermostat?
    But is it normal that the car is going into a emergency modus?

    Thank you.

  2. #2
    Regular Member
    Join Date
    Nov 2010
    Location
    luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hello, ive just replaced my thermostat today after the temp gauge showing cold for about a month, never had any spanner lights or service lights or the car going into emergency mode, sounds a bit more serious than the thermostat
    would recommend putting it on a computer mate

  3. #3
    Regular Member
    Join Date
    Sep 2010
    Location
    Netherlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for you reply.
    But when you compare the temp before and after the replacement of the thermostat what are you seeing?

  4. #4
    Regular Member
    Join Date
    Nov 2010
    Location
    luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hello mate, merry xmas

    before, the needle was exactly on the cold mark, it would move very very slightly above the C.

    once change, after about 2 miles it went straight to 85c

  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by genesisfm View Post
    Hello,

    Today my service light is coming up and my car switch to emergency modus.

    .
    The service light won't put your car into limp home mode. if its saying insp or a car with an oil can its just due a service, if its a car with a spanner its displaying its got an active fault.

    Just to try to clear things up
    Now I need a turbo to keep up!

  6. #6
    Regular Member
    Join Date
    Sep 2010
    Location
    Netherlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks!
    Merry xmas

    After 50km my car temp. is max 80 celcius.
    When i drive 20 km it's around the 70 celcius.
    I think i have to replace my thermostat.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. thermostat for z19dth , a wee question
    By simplesi in forum Engine & Drivetrain
    Replies: 5
    Last Post: 18th October 2012, 01:19
  2. Oil for z19dth
    By neill in forum Engine & Drivetrain
    Replies: 2
    Last Post: 18th July 2011, 18:45
  3. Z19DTH - Which Oil?
    By treadstone in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 3rd March 2011, 17:22
  4. Z19DTH Thermostat
    By iRocco in forum Engine & Drivetrain
    Replies: 3
    Last Post: 20th April 2010, 10:30
  5. z19dth
    By taralko in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 1st July 2006, 13:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •