User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: hid kit

  1. #1
    Regular Member
    Join Date
    Aug 2010
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question hid kit

    went to fit mine to my preface but cant get the bulb clip on am my missing something like these,

    http://cgi.ebay.co.uk/ws/eBayISAPI.d...=STRK:MEWAX:IT

  2. #2
    Regular Member
    Join Date
    Aug 2010
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    also would these flatten the battery being left on for a couple of Min's as when i go to start it it just makes a loud click/bang thanks.

  3. #3
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    I found the ones that came with my kit didn't fit, so I just used the original ones and 'stress broke' them at their thinnest points to allow the lamp cable through. Works perfectly.

    Unless this 'click/bang' is more like the puff of a match lighting in silence as you switch them on, I'd be checking for dodgy connections/sparking, etc.
    If all if connected properly, having the lights on for a few mins won't generally hurt.... just don't leave them on while you go for a cuppa and a warm up.

  4. #4
    Regular Member
    Join Date
    Aug 2010
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    OK thanks, there no noise when switching them its the car that wont start now but started before i put them on

  5. #5
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    I'd disconnect them at the part where the car loom meets the HID kit, then check all your fuses - you might have shorted something when fitting the kit. Get the car running, then worry about the HIDs - you can always revert to standard lighting if you need to use the car.

  6. #6
    Regular Member parttimer1's Avatar
    Join Date
    Dec 2010
    Location
    edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Should the kits come with these if you order a vehicle specific set? I'm looking to order over coming days so don't want too much carry on fitting.

  7. #7
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Quote Originally Posted by parttimer1 View Post
    Should the kits come with these if you order a vehicle specific set? I'm looking to order over coming days so don't want too much carry on fitting.
    Both sets I got came with 'modified' lamp retainers.

    The modification being that they have a cut to pass over the lamp cable.

    Whereas my original lamp retainers where quite angular where they 'bayonet fit' into the rear of the lamp housing, the supplied ones were far more rounded and I found them a total pig to fit - hence modifying my original retainers.

  8. #8
    Regular Member
    Join Date
    Aug 2010
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    got it all sorted now with a new battery as the hids killed mine what was left of it,now whats the best side lights and fog lights also high beam to put with the 6000k 55w kit any links please. thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •