User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: abs/airbag/power stearing/spanner light help ?

  1. #1
    Regular Member
    Join Date
    Feb 2008
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default abs/airbag/power stearing/spanner light help ?

    hi can anyone help
    drove car for a couple of miles today and battery light came on.started car a couple of hours later all seemed ok.just drove to the local tesco and back and on the way back my abs and airbag light came on shortly followed by power steering and spanner light.seemed to run ok but with no power steering.managed to get it home and plugged in to obd port for a check and it came up with fault p1109.tried to start car but seems to not have enough power in battery to start the engine.any idea of fault.could it be the alternator ?
    Last edited by learoy69; 10th December 2010 at 18:11.

  2. #2
    Regular Member
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had identical warning lights and loss of power steering a few months ago. Battery was drained . I replaced the alternator and everything has been fine since. The spanner warning light will stay on but will eventually clear.

  3. #3
    Regular Member
    Join Date
    Feb 2008
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers jimboy just need to find part number for alternator and how many amp it is

  4. #4
    Regular Member
    Join Date
    Feb 2008
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    does every 1 else think the same

  5. #5
    Regular Member mozzer99's Avatar
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by learoy69 View Post
    does every 1 else think the same
    I'd agree with Jimboy - but check the current battery terminals are tight and the earth's are good first. Check the earth's by using a jump lead from the battery negative to the engine direct.
    Ebay are doing new alternators from Denso (top Japanese OE brand) for £100 apparently.

  6. #6
    Regular Member StarDust2k5's Avatar
    Join Date
    Feb 2010
    Location
    Newport, Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    this happend to me, alternator had gone and after a few miles battery was drained. all lights came on and lost power to steering brakes etc which was scary. new alternator and 20k miles later all is good.

  7. #7
    Regular Member
    Join Date
    Dec 2008
    Location
    Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by learoy69 View Post
    hi can anyone help
    drove car for a couple of miles today and battery light came on.started car a couple of hours later all seemed ok.just drove to the local tesco and back and on the way back my abs and airbag light came on shortly followed by power steering and spanner light.seemed to run ok but with no power steering.managed to get it home and plugged in to obd port for a check and it came up with fault p1109.tried to start car but seems to not have enough power in battery to start the engine.any idea of fault.could it be the alternator ?
    When posting faults like this please supply car details for an accurate answer.

    Going by what you've said I'm going to base/guess your car on a 1.9 CDTI 2004-2007 Z19DTH ok.

    P1109-
    Fault location-
    Intake manifold air control actuator /
    Intake manifold air control actuator position sensor circuit malfunction.

    Probable cause-
    Wiring,
    Intake manifold air control solenoid,
    Intake manifold air control actuator position sensor.

  8. #8
    Regular Member BigWilko's Avatar
    Join Date
    Jan 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 3.0 CDTI

    Year : 2005

    Default

    Alternator buddy! I took mine to ATS and they id a battery and alternator check on it. Lost power steering in the way to the garage. No speedo or nowt. Dont think it put and miles on the clock though

  9. #9
    Regular Member
    Join Date
    Dec 2008
    Location
    Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just an after thought, what diagnostics are you using? I have TECH2 and OPCOM and use Autodata.

    If your using a basic general hand held scanner from flee-bay the code provided may not be accurate.

    Dealer level manufacturer specific diagnostics is a must on CAN-BUS cars like these.

    The fault code you provided may well be an additional fault to your post as an alternator or faulty battery does not always show up on a diagnostic, unless in live data. A decent multimeter will confirm alternator/battery and do a load test.
    Last edited by wcr; 11th December 2010 at 02:53. Reason: typo

  10. #10
    Regular Member
    Join Date
    Feb 2008
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers wcr
    it is a basic scanner. wonder if code was allready there before alternator fault
    thanks all alternator on order

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Spanner light & loss of power
    By kamar in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 9th January 2013, 23:10
  3. Power Stearing warning light
    By Dazbaz in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 13th March 2011, 20:57
  4. Spanner light on but no loss of power
    By jonesy1 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 1st May 2010, 12:58
  5. Engine Spanner Light And No Power
    By yamkwak in forum Engine & Drivetrain
    Replies: 39
    Last Post: 9th April 2008, 22:40

Visitors found this page by searching for:

opel vectra power stearing abs and battery lights on what.is it

engine start power stearing light

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •