User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Twang noise from front?

  1. #1
    Regular Member
    Join Date
    Oct 2010
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Twang noise from front?

    I have noticed a twanging noise from the front of my vectra, it would only be noticable when driving very slow and turning the steering, example when parking. It seems to be coming from the drivers side. I hope you can understand the sound I mean. Thinking its something in suspension maybe.

  2. #2
    Regular Member Rapala's Avatar
    Join Date
    Oct 2008
    Location
    Clackmannanshire Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You will more than likely have a broken spring, Very common on our cars.

  3. #3
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If the springs aren't broken, then the symptoms sound very much like another common issue, namely that the springs are "jumping" in their bottom seats. Vauxhall's fix is to wrap a nylon sleeve around the bottom few inches of the spring. It's available from Vx for a few quid and comes in two colours, blue and green, to denote different spring sizes. That should solve the problem, although Vx also highly reccomend spraying two coats of primer over the bottom few inches of the springs and putting grease on the lower spring seat.

  4. #4
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    I have heard this noise before too, just spring moving in the seat on the shocker. My last car did it from time to time too.

  5. #5
    Regular Member crispy007's Avatar
    Join Date
    Oct 2010
    Location
    lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    broken spring i had one go on my first vectra £38 fitted at kwik fit which wasnt to bad

  6. #6
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    The cause of my twanging was small stones and grit had got trapped between the base of the spring and bottom plate stopping it seating properly. Garage jacked the car up, put a screwdriver in to lift up the spring and blew out the debris with compressed air. Not been heard since.

  7. #7
    Regular Member Steve01's Avatar
    Join Date
    May 2009
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same problem with mine and the springs are fine as the guys say its just crap trapped in the strut between the spring and the base! I gonna get those sleeves to put on the springs to stop it! My local garage said its a very common thing and they suggested just try cleaning them as best you can and put some greasse in there!

  8. #8
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI

    Trim : FULL LEATHER

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 197,000

    Default

    hi fellow ni member , sounds like a strut top bearing needs replaced which causes the whole spring to turn and jump out off its seat

  9. #9
    Regular Member
    Join Date
    Mar 2010
    Location
    taunton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had new front springs fitted by dealer covered by Vauxhall as good will and after a couple of weeks later mine did the same but they could not fined any wrong apart from they said there was a stone stuck in the spring they said they took the stone out then it was all ok for a couple of months then it came back same noise took it to me mate who did work for Vauxhall he took the car up the road came back and said I know what is so he explained to me what I needed it was some rubber thing that is under the spring and it will cost about £4 for parts and about 45 mins to fit I had both sides done been fine ever since

  10. #10
    Regular Member Steve01's Avatar
    Join Date
    May 2009
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by peadar View Post
    hi fellow ni member , sounds like a strut top bearing needs replaced which causes the whole spring to turn and jump out off its seat
    Top strut bearings give of a different sound! More like a grinding!
    I replaced mine thinking thats what it was and it turns out its the spring problem not the bearings!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 8th September 2012, 12:13
  2. twang twang BANG !
    By gsxrster in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 11th March 2012, 21:27
  3. Twang
    By dominic32 in forum Suspension, Wheels & Brakes
    Replies: 9
    Last Post: 8th July 2010, 22:07
  4. twang from near side front coil
    By denzilbud in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 5th October 2009, 19:57
  5. 1 noise solved (front Bearing) + 1 new noise (squeaking front brakes!!!)
    By joseantoniovalle in forum Suspension, Wheels & Brakes
    Replies: 24
    Last Post: 30th September 2006, 08:54

Visitors found this page by searching for:

vectra c noise off spring

vectra c twang twang sound

twang sound when braking

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •