User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 7 123 ... LastLast
Results 1 to 10 of 61

Thread: poorley turbo on 2.0 T z20net

  1. #1
    Regular Member accveccysriturbo's Avatar
    Join Date
    Jul 2010
    Location
    west mids
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default poorley turbo on 2.0 T z20net

    Noticed over last few days the car was feeling a little off n then yesterday I started to hear a weird whirling/hissing sound. Anyway took it to my mate garage had full service done £45 labour but he and three others have advised turbo needs looking at in more detail.

    He has checked pipes n valves etc following some research on here from me.

    Suggests I take to VX to get it looked at.

    Car is 05 plate with 55k on clock n ****** warraty ran out 250 miles ago.

    Anyone any ideas on what it could be? Car still picks up but is noisey n seems to hold back under full throttle.

    Anyone know a turbo specialist in Birmingham area as would much preferred this than being conned by stealers.

  2. #2
    North Wales - Assistant Regional Organiser
    Join Date
    Feb 2010
    Location
    Wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like a wastegate problem if there's a hissing sound and it's a bit down on power. Any blue smoke out the back?

  3. #3
    Regular Member accveccysriturbo's Avatar
    Join Date
    Jul 2010
    Location
    west mids
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No smoke at all which makes me think its not a turbo fault. My mate didn't want to risk it hence his advice to take to VX.

  4. #4
    Regular Member rockhopper's Avatar
    Join Date
    Jun 2010
    Location
    Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    If the warranty ran out 250miles ago it might be worth taking it to the dealers and if there is a major issue they should come to some form of arrangement with you. If it isn't major then you can pay them the diagnostic charge and get it fixed somewhere cheap.

  5. #5
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    the hiising sound on mine was down to the little length od pipe the connects the compressor housing of the turbo the intercooler pipe that come up the back of the engine. It was difficult to see and missed by a mechanic i had look at it.

    Jack the car up and crwal underneath with a torch, shine it up the back og the engine following the intercooler pipe the feeds under the block then up to the turbo. There is a 3 inches of rubber pipe that connects it to the turbo. Mine has deteriorated just at the bottom of the runner pipe and was leaking from there. There are three jubilee clips, on hold the pipe to the turbo, one olding a small piece of heatshield around the rubber pipe and the bottom clips that connects the rubber hose to the intercooler pipe. I loosened off the heatshield one and saw the pipe pob, without doing that i would not have noticed it. I then loosened off the bottom clip and reseated the the intercooler pipe deeper into the rubber pipe with a little upward pressure which i kept on while I tightened up the clip enuring that the deteriotated bit was a below the clip. I then retightened the middle clip to reposition the small heatshield wrap.

    Hissing is generally down to a loose connection/leak, a split pipe is more rasping apparently. Check this pipe first, mine is not the only one to have had this. Its a free fix for a start.

    Let us know how you get on.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  6. #6
    Regular Member accveccysriturbo's Avatar
    Join Date
    Jul 2010
    Location
    west mids
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I got another mate looking at it Thursday. He thinks its something to do with a connection at the rear ny the turbo.

    I can't see it being the turbo these things are good for what 250 bhp plus it does move if you put your foot down but sounds like an air hose is going off in there hsssssssss.

    If you accelerate through each gear slowly there is no sound at all but put your foot down n it hisses. . There is no smoke oil or grinding noise at all.

    Given the fact I can go through the entire rev range in various gears with no juddering, and the sound only occurs as the boost goes up makes me think its a pipe.

  7. #7
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds just like mine did.. check that pipe bud, its a likely suspect.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  8. #8
    Regular Member accveccysriturbo's Avatar
    Join Date
    Jul 2010
    Location
    west mids
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hope so nige lol.

    Anyone know how much a new turbo costs n if I would be better sourcing one away from vauxhall.

    The 2k kit from neo brothers might have to be done lol

  9. #9
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    well if you have a turbo problem in the end, its cheaper to to buy one secondhand or send yours off to be refurbed, they can refurb them in a day. A new one from vx will cost loads more, about 900 quid i think.. You could always the repair place to hybrid it and make it more powerful while they are at it but you will need a mapper to visit you when you refit it to map your ecu to cope with it.

    The other alternative is the get hold of a secondhand mitsubishi td04 turbo as they seem to be more robust than these Garrett turbos but you will need to get a set of oil and water lines to cater for it, they range from 50 to 100 pounds depending on where you buy them.. Your map will need be adjusted for the mitsubishi turbo as well as they kick out more boost than the Garrett GT2052.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  10. #10
    Regular Member accveccysriturbo's Avatar
    Join Date
    Jul 2010
    Location
    west mids
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Midland turbo have good rep n presume its the same unit for the 93 or brothers would be a call to see if they do or know good place. Also turbo dynamics.

Page 1 of 7 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 6th September 2014, 13:54
  2. z20net 2.0t no turbo
    By mccluskey119 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 14th August 2012, 14:53
  3. TD04L14T turbo for Z20NET (2.0 turbo)
    By Caveman_nige in forum Parts for sale
    Replies: 3
    Last Post: 10th October 2010, 13:23
  4. z20net turbo
    By gibbon7000 in forum Engine & Drivetrain
    Replies: 25
    Last Post: 21st April 2009, 08:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •