User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Spanner light now stays on, them EML light!(1.9 150)

  1. #1
    Regular Member
    Join Date
    Apr 2010
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Eek Spanner light now stays on, them EML light!(1.9 150)

    I've got that sinking feeling! I have a 1.9 CDTi (55 plate) with 63k on the clock - I've had it about 9 months and most of the time when starting from cold I get the spanner light on for about 5 minutes but it disappears during the journey, it's been fine for months. Today I've picked the car up from the Body Shop Repairers (don't ask!) and instead of the usual "spanner light on for a while then going out" I get "spanner light on the whole way home".

    I tried stopping and starting my engine which normally clears it but it came back on and stayed on . I popped out earlier to go get some milk and bread, as you do, and then shock horror - the dreaded EML light
    Nooooooo!!!!! I have no CANBUS code reader but luckly I'm booked in for a service tomorrow at my garrage so hopefully I can get it fixed for not too much $$$. At the moment I'm suspicious of this body shop repair place as the car was running fine when it went in and they should not have gone anywhere near the engine.

    I've been reading up on the 1.9CDTi engine and can see it has it's flaws but I still love it - I'll ask my mechanic to check my diesel fuel filter for water, test all my glow plugs and maybe clean my EGR valve and boost sensor. The car has not had any modifications and is 100% stock (as far as i'm aware) so no third injector re-wiring work or modifed air filter changes have been made (although I do plan on getting this new inlet manifold at around the 100k miles mark )

    When I get it sorted I'll post up the findings and hopefully it will help one of you guys who may be having this issue

  2. #2
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    I would be inclined to say glow plugs. Maybe all are goosed now.

    If the car is running fine then I wouldn't worry too much.

    Gazza4

  3. #3
    Regular Member mozzer99's Avatar
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If I were to place a bet it would be the EGR sticking. The solenoid part needs to be cleaned and freed up, not just the actuator bit you can easily see. There is a 'how 2' - but I can't find it.
    Beware a garage will probably just renew the unit for £100+ labour?

  4. #4
    Regular Member
    Join Date
    Nov 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi i posted yesterday about the same problem! my spanner light comes on for about 3 mins then goes off, i also have a 1.9 cdti, im was told its glow plugs but it starts first time with no struggle,

  5. #5
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you can check glow plugs by taking each one out in sequence and then use 12v battery to wire up, they will get very hot mind so be careful

    so short term start up spanner light most likely glow plugs

    if its on longer then I'd say egr ( + boost sensor ) would be my first port of call

    I'd change my fuel filter in any case as it can only help to draw clean fuel throught the system

    cheers

  6. #6
    Regular Member felixx's Avatar
    Join Date
    Mar 2010
    Location
    stockport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation

    Quote Originally Posted by Gazza4 View Post
    I would be inclined to say glow plugs. Maybe all are goosed now.

    If the car is running fine then I wouldn't worry too much.

    Gazza4
    I am inclined to agree as if it were your EGR,you would be/have symptoms associated with the failure of,or problems with that unit.If it's just been the spanner light then nothing after start up,then you will probably find that they diagnose the glow plugs.Has it been ok after it's initial start up?,ie,no spanner light etc,etc?. FELIXX.

  7. #7
    Regular Member mozzer99's Avatar
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    incorrect post

  8. #8
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by mozzer99 View Post
    incorrect post

  9. #9
    Regular Member
    Join Date
    Apr 2010
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hello, thanks for the replies my mechanic said the engine management light is my EGR valve so it looks like Mozzer99 was right, spot on mate thanks for the reply. He said he could get me a price on a new EGR or if I find one and buy it he'll fit it for me for £30 which sounds good. My EML is still on but the car drives fine, no loss of power, no smoke, and starts to pull hard from 1500 revs all the way with no issues.

    He told me to give a blast on the Motorway every now and then and hold the revs which should help. I managed to find the how2 guide for cleaning the EGR valves, and even better someone has compiled it into a downloadable PDF so nuff thanks to "cdti150SRI 54est" for this it will be useful to a lot of us!

    http://www.vectra-c.com/forum/showth...ing+EGR&page=4

    If I can't find a new one cheap enough I'll get it cleaned up I think, I did read somewhere a bloke bought a GM one on ebay for £45

  10. #10
    Regular Member
    Join Date
    Apr 2010
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Smile

    Hi felixx just re-read your post! No the spanner light would come on only when starting from cold, it would stay light when the engine started and go out after driving for about 5 minutes. It would sometimes clear if you stop and start the engine which was the norm for about 8-9 months. I just noticed yeasterday that the spanner light would not clear and remained lit which was out of the norm - it stayed on during a journed of about 20 minutes. I left the car and went to go out later that day and got the dreaded EML

    I'm competent when it comes to fuses, relays or anything technical but I prefer to leave engine components to people who know their stuff! (and have the tools)

    P.S I've figured out how to upoad attachments so you can find the EGR cleaning PDF from 'cdti150SRI 54est'
    Last edited by adamf; 10th December 2010 at 23:12. Reason: Attachment EGR Clean PDF

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. numberplate light stays on
    By skip85 in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 24th January 2013, 17:25
  2. Petrol Warning Light Stays On
    By seanp in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 16th January 2012, 14:03
  3. Spanner Warning Light Stays On
    By Englishman in forum Vectra C / Signum Troubleshooting
    Replies: 15
    Last Post: 8th May 2011, 01:00
  4. Spanner warning light stays on
    By NeedleSharp in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 30th April 2011, 15:12
  5. Car and spanner light now stays on?
    By danny1992 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 7th December 2010, 14:04

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •