User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: 3.2 Elite central screen problems

  1. #1
    Regular Member crucial's Avatar
    Join Date
    Oct 2007
    Location
    kent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 3.2 Elite central screen problems

    The centre screen in my 2003 Vectra c 3.2 Elite has started to flash on and off constantly. When i switch off the engine, the climate control keeps blowing. Im having to disconnect the battery to make it switch off, otherwise it would run all night and all day. I,m not sure if anyone has had this fault and might offer advice. The car is virtually unusable in this state because i cant park anywhere without disconnecting the battery. Can anyone help please, im pretty desperate.

  2. #2
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds like a broken screen.

    replace with new.

  3. #3
    Regular Member crucial's Avatar
    Join Date
    Oct 2007
    Location
    kent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks Kenp. I understand there is a connector at the back of the screen, is it possible this may of become loose? It does seem that going over bumps makes the screen flash on and off sometimes, so i guess a connection may be at fault. Im wondering if a quick removal, plug out, plug in, might possibly fix it.Anyone have experience with this problem? I wonder how much the screen is? Hopefully around £100 or so might cover it?

  4. #4
    Regular Member kman247's Avatar
    Join Date
    Nov 2008
    Location
    milton keynes
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by crucial View Post
    Thanks Ken. I understand there is a connector at the back of the screen, is it possible this may of become loose? It does seem that going over bumps makes the screen flash on and off sometimes, so i guess a connection may be at fault. Im wondering if a quick removal, plug out, plug in, might possibly fix it.Anyone have experience with this problem? I wonder how much the screen is? Hopefully around £100 or so might cover it?

    Depends what stereo you have to what screen you will need , to prove its the screen at fault just unplug it

  5. #5
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yes there is a 32pin connector on the back..

    Ive never head about it comming loose.. but quick to find out.

    well depending on what radio you have.. you can get screens for about 40£ and upwards on ebay.. i dont know how much they are from new.. but not cheap.

  6. #6
    Regular Member crucial's Avatar
    Join Date
    Oct 2007
    Location
    kent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    The radio i have is a 3 cd changer thing that goes in a slot, not sure of the number, can anyone help with the screen i need?

  7. #7
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    There are 3 different with a CD-changer..

    CCR 2006
    NCDC2013
    NCDC2015

    if its one of the 2 NCDC range, its not just find one on ebay, but a bit more fidly.

  8. #8
    Regular Member crucial's Avatar
    Join Date
    Oct 2007
    Location
    kent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    It's the CCR 2006, is it just plug and play? I have the stereo code, will that all still work with the new screen attached, or is there more i need?

  9. #9
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    when you have the CCR then it should still work

  10. #10
    Regular Member
    Join Date
    Feb 2010
    Location
    Aberdeen Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    http://www.vectra-c.com/forum/showthread.php?t=86568

    Have aread of this thread could be your problem, I still have the problem the cold seems to affect it as works fine in summer time but as soon as it hits 3 degrees it starts to flash on and off and it does this up to -5 degrees, -6 works alright so something doesn't work from 3 to -6 degrees!!!

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Central Heating problems
    By phil67 in forum The 'Off Topic' room
    Replies: 2
    Last Post: 9th April 2012, 21:04
  2. Central Locking and Alarm Problems
    By Griff72 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 4th November 2010, 08:15
  3. central screen price o3 elite
    By luc4$ in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 13th May 2010, 20:37
  4. central screen problem
    By luc4$ in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 20th April 2010, 13:25
  5. Elite screen (53 plate)....
    By danBoy in forum Parts for sale
    Replies: 6
    Last Post: 20th January 2008, 14:32

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •