User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Engine Trouble

  1. #1
    Regular Member
    Join Date
    Jan 2010
    Location
    Lisburn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine Trouble

    I own a 150bhp 2004 Vectra

    I have had a look over the forum but not sure whats specfic to my problem, possibly EGR valve.

    The car for the last few weeks was having trouble starting, next step, trouble starting and very clunky engine idle, the car wouldnt rev over idle speed for a few minutes and eventually with the accelorator pressed it rev'ed and car was fine. Until this morning it wouldnt start at all and i ran the battery dead.

    I dont know much about diesels so thought it maybe the glow plugs, I had a go fitting them today after work, I found 1 had snapped from previous owner as it came out without ahead (no problems in my removal) so I tighned it back up and replaced the other 3. Charged the battery and the car still wont start....

    To describe what happens, the engine sounds like its trying to fire, it sounds like its about to start but never quite reaches that final point.

    Im at a loss of what to do tbh, any help will be appreciated

  2. #2
    Regular Member
    Join Date
    Jan 2010
    Location
    Lisburn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just resolved most of the problem, Cleaned the EGR valve completely, solinoid too via drilling etc and also did the boost sensor.

    Car starts 100% and alot smoother, no noticable hesitation with the revs and sounds alot healthier. I disconnected the battery also to clear the spanner warning symbol.

    As smoother as it seems though, i cant help think it has a couple off flat spots, and slight loss off power (altho i hope its my imagination as have been driving the bmw 330ci last few days)

    There is that yellow light on underneath petrol gauge, is that an ecu light or something? or is it normal. Any ideas?

  3. #3
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Try the injector plugs also, remove one at a time & spray with electrical contact spray!, then have a look at the how 2 for the 'clean & repair the throttle body'' this will help & hopefully solve it for sure.

    http://www.vectra-c.com/forum/showthread.php?t=119346

  4. #4
    Regular Member
    Join Date
    Jan 2010
    Location
    Lisburn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks very much! will have a go at that later, very useful

  5. #5
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    do the airbox mod and put premium fuel like vpower or BP ultimate in it for a couple of tanks

    that should clean up injectors nicely

    and improve performance

  6. #6
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    The little yellow light under the fuel gauge is the emissions light. You have a malfunctioning EGR valve imo.

    With regards to the throttle body if you are experiencing violent juddering and unexpected shut downs then I would say the throttle body electronics have became open circuit. Your car is 2004 so it is possible that will suffer thsi albeit I don't think this is the problem in this case. I would say it is the EGR valve as you cleaned it and the light came on.

    If I were to unplug the EGR valve on mine after a period of time that emissions light would come on.

    Gazza4

  7. #7
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i used to get shutdown judder but i now leave engine to run for a minute or so on tickover before closing down, no such problems now....

    accept the electrics in throttle body can be a pain

  8. #8
    Regular Member
    Join Date
    Jan 2010
    Location
    Lisburn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thought everything was going fine until this morning.

    Was leaving the car with the light on for a while until the snow cleared, have someone I know with a laptop to plug the car into to test fully.

    Now though I seem to be back to square one, even after cleaning the EGR valve and it was PERFECT (apart from the light) power was better than it ever had been under my ownership. (to confirm it wasnt starting, cleaned EGR, then started and was working well)

    But now she wont start again, same issue .... there is that little hole i drilled to get to to the solinoid, is it possible moist air has got in and ceased it?

    Im guessing New EGR valve completely? what you think.. arghh Cars are great when their running but when their not lol ugghh

  9. #9
    Regular Member
    Join Date
    Jan 2010
    Location
    Lisburn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anyone recomend blanking the egr valve too? I assume this stop the egr getting dirty once clean? (if I need a new one)

  10. #10
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Some have blanked the EGR valve and most have fitted the Fiat restricting gaskets. I have fitted the Fiat restrictor plates.

    Gazza4

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. engine trouble
    By Sigchris in forum Engine & Drivetrain
    Replies: 1
    Last Post: 15th May 2012, 21:57
  2. engine trouble?
    By clembo38 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 21st February 2011, 23:18
  3. Help: More engine trouble!
    By Marky in forum Engine & Drivetrain
    Replies: 4
    Last Post: 29th April 2010, 16:34
  4. Engine Trouble
    By Darrent in forum Engine & Drivetrain
    Replies: 1
    Last Post: 12th March 2010, 14:50
  5. Please help engine trouble!
    By regishaunus in forum Engine & Drivetrain
    Replies: 15
    Last Post: 8th November 2007, 12:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •