User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: heater help and advice needed urgently

  1. #1
    Regular Member callum's Avatar
    Join Date
    Jun 2009
    Location
    stafford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Eek heater help and advice needed urgently

    hi people first sorry aint been on in a while i had my laptop stolen and only just been able to replace it.
    i have a heater problem my heater this morning was ok but now at 6pm noticed it was not working on the dials 1.2 and 3 but as normal working as should on number 4.
    but however i have no heat coming out of my blowers i have checked that water is still pumping through so water pump is ok and water was warm i just cant understand what may have happened please someone give me advice thanks ever so much i have the 2.2 dti sri on a 52 plate thanks.
    only problem is i take my kids everywhere and dont want them gettig too cold in the car all while...

  2. #2
    Regular Member mhvcbv's Avatar
    Join Date
    Sep 2007
    Location
    cambs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi m8
    sounds like the heater resistor(comman problem)
    have a look on ebay they go for around £20ish

  3. #3
    Regular Member callum's Avatar
    Join Date
    Jun 2009
    Location
    stafford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Thumbs up heater

    hi mate thanks for that i have just bought one 26.00 quid
    would this be why its not blowing heat also thanks mate much appreciated

  4. #4
    Regular Member callum's Avatar
    Join Date
    Jun 2009
    Location
    stafford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    any one would this be why its only blowing warm air thanks

  5. #5
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Low coolant level? maybe air trapped in the heat exchange matrix?

  6. #6
    Regular Member
    Join Date
    May 2009
    Location
    swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As far as I'm aware the resistor only controls the fan speed. The heat is controlled by the large central knob. Assuming your cooling system is working ok.

  7. #7
    New Member
    Join Date
    Nov 2010
    Location
    Chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Callum,

    Im a new member and I have experienced the same thing, my fan did not work on 1,2,3 but worked on setting 4. Everything else worked including the heating. I bought a Thermo fuse from Maplins for 79p and took the old one off and soldered the new one on. I had to drop the glovebox out to do this.

    Now I have a fully functioning fan. I knew from other posts on here it was the thermo fuse or the resister pack but wanted to check the inexpensive item first without shedding out for the resister pack.

    Thought I would share just in case you wanted to consider this and test this first.

    Ian

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.0dti Diesel pump advice urgently needed
    By ads3 in forum Diesel Engine related
    Replies: 3
    Last Post: 14th June 2011, 15:33
  2. Gearbox Oil Level Advice Urgently Needed Please **
    By Jezzy in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 2nd July 2010, 19:02
  3. Help & Advice Urgently Needed
    By lfcfan85 in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 9th November 2009, 20:05
  4. needed urgently
    By andy.l in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 22nd February 2007, 12:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •