User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 'Safe Guard' message (Codes inc)

  1. #1
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default 'Safe Guard' message (Codes inc)

    Since buying my Signum I have always had the 'Safe Guard' message.

    I have read the codes and this is what I have got:

    Total number of fault codes: 3

    B2955 - Anti Theft Warning System Sensor Datalink Circuit Low Voltage or Circuit Open
    (06) - Present

    B2955 - Anti Theft Warning System Sensor Datalink no Communication
    (0F) - Present

    B3916 - Powersounder Malfunction
    (39) - Not present



    I have replaced the ultrasonics with a working one from a member on here and the Power sounder one can be cleared but comes back now and again.

    How do you replace the power sounder? Do they need coding to the car if I get a second hand one?

  2. #2
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Try setting your alarm off...

    Sounds to me like someone has tried the "make your alarm louder" trick

    This entails just unplugging the power sounder in the boot / load area, so that the car uses the Horn(s) instead.

    If your sounder is present and fitted, try checking the multitude of fuses in the rear fuse box.

    It may also be that the power sounder was unplugged due to a flat sounder battery - this would result in the alarm going off randomly... usually at three in the morning.

    So the options are: -
    1) Sounder Unplugged
    2) Blown / missing fuse
    3) A final thought - BCM or REC or DIS have not been programmed fully to recognise the alarm as "present" in the variance coding

  3. #3
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Any idea what fuse to check?

  4. #4
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Here you go... from the Vectra owners manual

  5. #5
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Ah thats great.

    I take it the Signum is the same (As thats what I have)

  6. #6
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Yep -should be...
    Signum is virtually an upgraded Vectra-C estate.

    Uses the same floor plan etc.

  7. #7
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Thats great,

    Thanks for the help.

  8. #8
    New Member
    Join Date
    Jun 2007
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I too have been suffering from random alarm activations - the codes are the same as above -

    B2955-06 - Anti Theft Warning System Sensor Datalink Circuit Low Voltage or Circuit Open

    B2955-0F - Anti Theft Warning System Sensor Datalink no Communication

    B3916-0F - No communication with alarm siren.

    So is it the Ultrasonic module that is goosed? I did try the car with the Ultrasonics switched off from the instrument panel - I guess the unit is probably still powered up though.

    If the unit is goosed, is it easy to change and rough cost?

    Thanks

    Lindsay

  9. #9
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Fitted a known working set and mine still has the warning.

  10. #10
    Regular Member zafira's Avatar
    Join Date
    Aug 2010
    Location
    North of Norway
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same problem today. Change fuse 21 and 23 and everything its ok. Is your alarm ok now?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. keeping your car keys safe! really safe
    By nicj in forum General Chat
    Replies: 48
    Last Post: 10th November 2012, 15:15
  2. Power Tail Gate & Safe Guard
    By Hursty103 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 4th July 2012, 14:49
  3. Cars says check safe guard
    By Sri-chris in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 13th December 2011, 23:35
  4. Safe guard
    By larrysSRI in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 27th January 2011, 10:31
  5. Safe Guard
    By Marc Hutton in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 5th October 2008, 17:45

Visitors found this page by searching for:

https:www.vectra-c.comforumshowthread.php123387-Safe-Guard-message-(Codes-inc)page2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •