User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Heater working but not great

  1. #1
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater working but not great

    I don't know if i'm just geeting nesh in my old age or I have a problem with the car.

    The heater works fine on all settings it just doesn't feel that warm on full heat and setting 4.

    I just have the normal aircon (not cllimate) and the air con is off.

    Any ideas? Is it me or the car

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    How long does the engine take to get warm, and what does the temp gauge indicate?

  3. #3
    Regular Member Grumpy1954's Avatar
    Join Date
    Mar 2010
    Location
    Newport (Shropshire)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Ford Kuga

    Trim : Titanium

    Engine : 2.0dtci

    Year : 2014

    Mileage : 1200

    Default

    My heater is very warm, so I'd say something wrong. Is the car fully warming up? Mine takes around 5 miles to get to full operating temp - any signs Thermostat on it way out?

  4. #4
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not noticed any engine temp problems, but I havn't been looking.

    I will check what happens on the way home tonight.
    I do a 25 mile journey to work. So it should show something by the time I get back home!

  5. #5
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just got home and the needle did not move from zero the whole journey.
    So somethings knackered

    What should I check?

    How does the thermostat affect the heater??

  6. #6
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by Marky View Post
    Not noticed any engine temp problems, but I havn't been looking.
    That would explain why you've not noticed anything then

    Quote Originally Posted by Marky View Post
    Just got home and the needle did not move from zero the whole journey.
    So somethings knackered ??
    Thermost stuck open and not allowing engine to get hot. It needs to be closed for a certain amount of time to allow the engine to get hot, then it will open and close accordingly to regulate the engine temperature.

    In short, you need the theromstat replacing.

  7. #7
    Regular Member Steve01's Avatar
    Join Date
    May 2009
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine doing the same and its defo the thermostat. Will have to wait til I come home now though, away offshore tomorrow! Ho hum

  8. #8
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Oh poo. Any idea of costs for replacing a thermostat.

  9. #9
    Regular Member Steve01's Avatar
    Join Date
    May 2009
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not sure on yours Marky but mine only about 15 quid to buy and its easy enough to do but I have a 1.8 Petrol!

  10. #10
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ive had a quick look on ebay and its just under £40 for the thermostat and would also need to replace the coolant.

    But it looks like its a horrible job on the 1.9 (120).

    Hopefully a garage could replace it in a couple of hours??
    So probably looking at £150-200????

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. heater not working - help please
    By wardy in forum Bodywork & Interior
    Replies: 14
    Last Post: 11th May 2015, 21:53
  2. heater not working
    By Dan. in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 7th May 2012, 09:02
  3. Heater not working
    By Shadrack in forum Engine & Drivetrain
    Replies: 0
    Last Post: 25th February 2012, 19:54
  4. Fitted and working great
    By jb1kenoby in forum Electrical & ICE (including SatNav)
    Replies: 19
    Last Post: 17th May 2010, 10:59
  5. Heater no Working, no hot air Help Please!
    By darkstar32 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 6th June 2009, 16:04

Visitors found this page by searching for:

vectra c heater temperature not accurate site:www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •