User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: 1.9CDTI (150) Won't Rev When Started

  1. #1
    Regular Member
    Join Date
    Dec 2008
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.9CDTI (150) Won't Rev When Started

    In the last few days my Vectra has been having this problem.

    Car starts fine, then ticks over a bit low, maybe about 800 rpm (normally 1k rpm).

    I press the accelerator to try to rev it and it creeps up the revs to about 2k rpm.

    After doing this a few times the engine picks up and rev's normally and continues to do so for the rest of the journey.

    Yesterday i did the 3rd injector mod with the new connector but it didn't cure it.

    I'm tempted to get 4 more of the kits and redo all 4 injector plugs.

    Or i was thinking this sounds a bit like a sticking EGR valve?

  2. #2
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    247 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    EGR valve
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  3. #3
    Regular Member
    Join Date
    Dec 2008
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Car was fine today, i been meaning to take off the EGR and clean it and put on the fiat gasket anyway so maybe this is the push i needed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vectra 1.9cdti and astra 1.9cdti clutch
    By abz123 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 13th October 2012, 21:01
  2. Well its started
    By bigmac in forum Styling
    Replies: 11
    Last Post: 28th January 2011, 17:43
  3. 1.9cdti juddering when started
    By mark-1-spark in forum Engine & Drivetrain
    Replies: 9
    Last Post: 28th March 2010, 20:33
  4. 1.9CDTi EML light on until engine started
    By brianrh in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 26th August 2008, 08:23
  5. Its started
    By SelbyVX in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 19th February 2007, 21:19

Visitors found this page by searching for:

2008 1.9cdti astra wont rev

vectra cdti 150 wont rev

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •