User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Egr valve / now engine management ?

  1. #1
    Regular Member
    Join Date
    May 2010
    Location
    cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Egr valve / now engine management ?

    Hi all,

    Firtsly great site and great info ( very helpful )
    Right here we go..for some time now spanner light been coming on for say a month with no difference in power,would only stay on for 5 mins then go off..anyway for the last week car has been flat power wise and wouldnt go until 2000rpms then if was off like normal.Anyway after looking on the site and reading alot on the egr valve i decided to take it off and clean ( also replaced fuel filter ) Anyway car now runs well again so great info.
    Dont know if spanner light back on yet as hasnt been stood long enough to see ( only came on when cold or left for hours)
    Anyway MAIN QUESTION IS..i took leads off battery to try and clear that spanner light? left off for over an hour, sine then i now have ENGINE MANAGEMENT LIGHT ON?
    Any input or ideas lads?
    Thanks for any advice.
    Steve

  2. #2
    Regular Member
    Join Date
    May 2010
    Location
    cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anybody?

  3. #3
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    im sure the diesel boy will enlighten you shortly but welcome anyway

  4. #4
    Regular Member felixx's Avatar
    Join Date
    Mar 2010
    Location
    stockport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Arrow

    Quote Originally Posted by steveo273 View Post
    Anybody?
    When the EGR valve throws up a problem,the fault code is PO400,if the problem is not rectified,(like when you blank it off),the spanner light is replaced by the engine management light.This will go out after a set amount of "start up's"etc,).If you have,or can get hold of, a code reader,check the codes,then erase them.This should turn out the engine light,unless there is another problem,however what you have described is just what you would expect after an EGR "issue".FELIXX.

  5. #5
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi

    at first guess it could be one of several things

    1) glow plugs .....that tends to cause a short illumination of lamp that then goes after a few minutes. you can remove and test each one if you don't want to replace but at about £40 a set coming into winter, i'd be replacing anyway every 3 years as a maintenance issue

    2) egr is most likely bet. strip, clean and replace as per how 2. make sure gaskets are cleaned or bette still replaced.....make sure you clean the intake where egr attaches to manifold trying not to drop carbon deposits into inlet. use carb cleaner and soft toothbrush. strip solenoid, clean and rebuild using wd40 , white lithium grease spray as lubricant



    3) clean boost ( map ) sensor.... carb cleaner and soft toothbrush

    4) clean maf sensor ----pure alcohol

    after that you should be in a better place. for the price of £10 ( two cans of carb cleaner) you should eradicate the lights you mention.

    whilst there do a oil / air filter change and notice the difference

    any questions let us know

  6. #6
    Regular Member
    Join Date
    May 2010
    Location
    cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Felix and Mparks,
    Firstly i did take egr valve off and clean it and that fixed my main problem which was not pull beneath 2000rpm..car seems to run fine now..
    My problem was i use to get spanner light on just when car was cold but did go off after 5 mins..would only come on when cold..anyway after i took egr valve off and cleaned it ran well... So i read on here that if i disconnected battery for an hour it would clear the spanner light ( which it has ) BUT now engine manange ment light is on..been on a week now, So im hoping that after so many starts it goes off ? could that happen?
    Dont think its any other reason as car seems spot on. And yes just replaced fuel filter,oil filter and air filter and oil etc..
    Cheers
    Steve

    PS great useful site ;-)

  7. #7
    Regular Member felixx's Avatar
    Join Date
    Mar 2010
    Location
    stockport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Thumbs up

    Quote Originally Posted by steveo273 View Post
    Hi Felix and Mparks,
    Firstly i did take egr valve off and clean it and that fixed my main problem which was not pull beneath 2000rpm..car seems to run fine now..
    My problem was i use to get spanner light on just when car was cold but did go off after 5 mins..would only come on when cold..anyway after i took egr valve off and cleaned it ran well... So i read on here that if i disconnected battery for an hour it would clear the spanner light ( which it has ) BUT now engine manange ment light is on..been on a week now, So im hoping that after so many starts it goes off ? could that happen?
    Dont think its any other reason as car seems spot on. And yes just replaced fuel filter,oil filter and air filter and oil etc..
    Cheers
    Steve

    PS great useful site ;-)
    Yes.It should go off.....eventually!!,that is unless there is an underlying problem,(which I don't think there is).If you have access to a code reader you could erase it without any problems,and then,if you had another problem,the spanner light would come on like it did in the first place.FELIXX.

  8. #8
    Regular Member felixx's Avatar
    Join Date
    Mar 2010
    Location
    stockport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation

    Quote Originally Posted by felixx View Post
    Yes.It should go off.....eventually!!,that is unless there is an underlying problem,(which I don't think there is).If you have access to a code reader you could erase it without any problems,and then,if you had another problem,the spanner light would come on like it did in the first place.FELIXX.
    Forgot to add,some of the other members on here have left their battery disconnected overnight to erase the EML.I'm sure someone could give you advice in that direction,although it shouldn't do any harm other than leave you without your alarm system.FELIXX.

  9. #9
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by steveo273 View Post
    Hi Felix and Mparks,
    Firstly i did take egr valve off and clean it and that fixed my main problem which was not pull beneath 2000rpm..car seems to run fine now..
    My problem was i use to get spanner light on just when car was cold but did go off after 5 mins..would only come on when cold..anyway after i took egr valve off and cleaned it ran well... So i read on here that if i disconnected battery for an hour it would clear the spanner light ( which it has ) BUT now engine manange ment light is on..been on a week now, So im hoping that after so many starts it goes off ? could that happen?
    Dont think its any other reason as car seems spot on. And yes just replaced fuel filter,oil filter and air filter and oil etc..
    Cheers
    Steve

    PS great useful site ;-)
    Usually if u get a spanner light on cold start ups and it goes off soon after you have a duff glowplug

  10. #10
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    First of all don't go near the MAF m8 - yet anyway - you may create another issue. They are very fragile and if you break it you are looking at £100+ to rectify.

    Looking at the facts you took the EGR valve off, cleaned and replaced and also changed the Fuel filter. One of these I would say is either not electrically connected properly (wouldn't surprise me if the EGR valve isn't). Check all electrical connections first.

    The engine management light is the the spanner light m8, I assume you are talking about the little yellow engine symbol - as that is the emissions light. So I say give the EGR area a check and make sure it is sealed too - gaskets etc and get the codes read. If the EGR valve is not the problem, then I would look at the MAF, as faulty ones will usually cause the emissions light to come on.

    Disconnecting the battery returns the ECU so factory settings - ie it forgets what it learned - ie the way you drive and what the different sensors are reporting back.

    Gazza4

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine lumpy now Engine Management Light is on
    By Fitzy-2.0T in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 17th July 2012, 16:51
  2. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  3. EGR Valve/engine management light
    By sleeper341 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd October 2010, 13:07
  4. Replies: 3
    Last Post: 28th April 2009, 19:49
  5. just had engine management done
    By MAF 3.2 V6 GSi in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 29th June 2007, 19:25

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •