User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Noise from front suspension

  1. #1
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Noise from front suspension

    I get a ?clunking? noise from the front when I drive off and sometimes a weird rattle when driving on rough roads (i.e. every road ). What's the problem now? Replaced drop links, tie rods + tie rod ends and wishbones not even 6k miles ago. The springs were checked 6k ago and tested fine, so did the shock absorbers...

    Also, there is a horrible knocking noise coming from the back. Would that be bad upper control arms?

  2. #2
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Anyone?

  3. #3
    North Wales - Assistant Regional Organiser
    Join Date
    Feb 2010
    Location
    Wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Mine's doing this. Running out of ideas as to what it might be. Worn suspension bushes? anti-roll bar? Need to get it up on ramps.

  4. #4
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    There are two obvious things you haven't changed yet, so it could be those: for the front it could be the anti-roll bar bushes, and at the rear it could be the upper control arms. Hold the rear tyre at the top and see if it moves in and out a little.

  5. #5
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Celes, the clunking when driving off is probably a worn CV joint.

  6. #6
    Full Member bobssignum's Avatar
    Join Date
    Dec 2007
    Location
    polishing something or other somewhere
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Is the clunking from the front end definetly suspension related or could it be radiator mounts
    Driving vauxhall,s for 30 + years
    and still loving it

  7. #7
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Jezzy View Post
    There are two obvious things you haven't changed yet, so it could be those: for the front it could be the anti-roll bar bushes, and at the rear it could be the upper control arms. Hold the rear tyre at the top and see if it moves in and out a little.
    Will replace the ARB soon. I've tried to move the rear tyre and it won't budge. I'll try again tomorrow.

    Quote Originally Posted by lesj View Post
    Celes, the clunking when driving off is probably a worn CV joint.
    Thought about that too...not for long though cos it's really expensive to repair

    Quote Originally Posted by bobssignum View Post
    Is the clunking from the front end definetly suspension related or could it be radiator mounts
    Haven't considered this but when I flushed the coolant 10k ago the radiator mounts looked ok...

  8. #8
    New Member
    Join Date
    Jan 2010
    Location
    uk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    hi guys it could be the front strut bearings i have the same issue going to replace on monday will let you know if this fixed the issue

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Noise from front suspension. Don't know where from
    By Lao in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 11th November 2009, 18:54
  2. Front suspension noise ?
    By caravaner-tony in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 25th November 2008, 01:35
  3. Front suspension noise..
    By baard in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 7th November 2007, 20:16
  4. front suspension noise?????
    By kev bux in forum Suspension, Wheels & Brakes
    Replies: 0
    Last Post: 20th June 2007, 18:46
  5. front suspension noise
    By Beavis in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 11th January 2006, 11:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •