User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Vectra C turbo problems

  1. #1
    New Member
    Join Date
    Feb 2010
    Location
    kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra C turbo problems

    Hi all,

    i have had problems on and off with my vecra for nearly a year now but since the cold weather started it has been almost constant.

    I can be driving it in any gear and at any speed and the turbo will just cut out and it will become really slow.
    Before last week everytime it was doing this, a car with a spanner would appear. I could turn it off then back on and it would be ok again.

    Last week i had the same problem but the engine management light came on, after turning it off and on 5 or 6 times the light was still there and has been ever since even though the power comes back occasionally for a few minutes.

    I had them run a diagnostics a few months ago when the problem was less frequent and it came up with these fault codes:

    P1105 barometric pressue
    P0105 vacuum solenoid circuit high
    P1590 high solenoid value

    I was told by the garage (not vauxhall) that they thought it was the solenoid but after looking on the internet i read about alot of people that had this changed but still had the same problem.

    Does anyone have the same problem or have any experience with this? What are the most common things that may cause this?

    Many thanks in advance for your replys

    Michelle
    xxxx

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Firstly I would check all the hoses for splits and clean the turbo pressure sensor as its a 2.2 dti
    Now I need a turbo to keep up!

  3. #3
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    Lol how do you know that engine it is....
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  4. #4
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Also seeing as its a 2.2dti try cleaning the boost sensor and the egr valve as it doesnt cost a penny and seems to solve alot of problems

    I have a feeling big sig calls it a turbo pressure sensor

  5. #5
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Quote Originally Posted by Caveman_nige View Post
    Lol how do you know that engine it is....
    Profile

  6. #6
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Caveman_nige View Post
    Lol how do you know that engine it is....
    2004 2.2dti elite

  7. #7
    New Member
    Join Date
    Feb 2010
    Location
    kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    just checked all of the rubber hoses i can get to and none seem to have any splits in them.
    Where would i find the other things and how do i clean them?
    I dont mind getting dirty but dont want to mess it up anymore than it is!

    Thanks

    Michelle
    xxxx

  8. #8
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






  9. #9
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Have a look in the 'how 2' section on this forum, there should be details on removing & cleaning the EGR & boost sensor, these are fairly easy jobs. as above! beat me to it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra 2.0 Sri Turbo Front Fog Problems
    By oodjsparkiedeeoo in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 26th March 2012, 21:51
  2. turbo problems
    By bobthebarber in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd January 2012, 20:35
  3. Turbo problems?
    By warren77 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 14th May 2011, 12:04
  4. turbo problems
    By chrisgo in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 13th January 2011, 15:32
  5. Turbo problems 2.0 Dti
    By brotherkennyh in forum Engine & Drivetrain
    Replies: 6
    Last Post: 27th August 2010, 12:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •