User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: 2.0 Turbo Rear Brake Pad issue

  1. #1
    Regular Member a1ant's Avatar
    Join Date
    Jul 2010
    Location
    England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.0 Turbo

    Trim : SRi

    Engine : 2.0 Turbo

    Year : 2006

    Default 2.0 Turbo Rear Brake Pad issue

    Hi all,

    I have been suffering from an annoying rattle/knocking noise from the rear drivers side of the car. I've had it for a few months and thought I had tried everything. I checked all the suspension for worn bushes/drop links etc. I even removed the rear bumper thinking it may be something loose under there

    Well today I have FINALLY found the cause. On the rear drivers side, the inner most pad is rattling around and jumping about when the disk is turning. I have looked in the guides section on here and see that the GSi has a spring clip on the rear of the pad that clips around the calliper piston to hold the pad.

    My question is, can anyone confirm if the 2.0 Turbo SRi should also have this spring clip? And if so, is the only option a set of new pads that this time HAVE the spring clip on the back?

    Many thanks in advance,

    Alan

  2. #2
    Regular Member signumturbo04's Avatar
    Join Date
    Dec 2009
    Location
    SCOTLAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes the rear pad (piston side) has a metal spring clip. my 2.0t signum has anyway lol

  3. #3
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    yes mate, there is a newer set of pads available with the clip.. dealers will seel them and mintex versions are available on ebay.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  4. #4
    Regular Member a1ant's Avatar
    Join Date
    Jul 2010
    Location
    England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.0 Turbo

    Trim : SRi

    Engine : 2.0 Turbo

    Year : 2006

    Default

    Thanks for the replys!!

    Ive seen two types of clips ....



    And then these:


    The bottom set have the spring clip on the top, as opposed to on the rear

    Any one seen the second type? I cant see how it would work myself.

    Many thanks,
    Alan

  5. #5
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    the second 2nd set are the ones you need
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  6. #6
    Regular Member a1ant's Avatar
    Join Date
    Jul 2010
    Location
    England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.0 Turbo

    Trim : SRi

    Engine : 2.0 Turbo

    Year : 2006

    Default

    Brilliant! Thanks!

    Just ordering them now. What oil do you recommend for the 2.0 Turbo? 0w30 or 5w30?

    Thanks again,
    Alan

  7. #7
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    i use 5/30 fully synth castrol
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  8. #8
    Regular Member a1ant's Avatar
    Join Date
    Jul 2010
    Location
    England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.0 Turbo

    Trim : SRi

    Engine : 2.0 Turbo

    Year : 2006

    Default

    Thanks Nige your a star!

    Alan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra c turbo rear brake caliper tool
    By davedave in forum Suspension, Wheels & Brakes
    Replies: 18
    Last Post: 23rd January 2013, 18:35
  2. Turbo issue
    By kman247 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 25th September 2011, 20:49
  3. CDTi 150 Turbo issue !!
    By mark_647 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 28th June 2009, 18:08
  4. Turbo issue???
    By duncatr in forum Engine & Drivetrain
    Replies: 4
    Last Post: 23rd December 2008, 14:10
  5. Turbo issue on 1.9 CDTI 120
    By RichieClyde in forum Engine & Drivetrain
    Replies: 11
    Last Post: 9th July 2008, 09:39

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •