User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: loss of power

  1. #1
    Regular Member
    Join Date
    Dec 2008
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default loss of power

    vectra 2.2 petrol,car with spanner light came on got home in limp mode revved engine light goes out but comes back on when i try to drive it any ideas cheers rick

  2. #2
    Regular Member hoochydady's Avatar
    Join Date
    Jan 2010
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could be any thing from a dirty egr to the fuel presure regulator or fuel pump as there common probs on the 2.2s mate

  3. #3
    Regular Member
    Join Date
    Dec 2008
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    fuel pump rail sensor and regulator all replaced 25k ago,when i restart the car runs ok for a bit then goes back to limp mode baffled

  4. #4
    Regular Member hoochydady's Avatar
    Join Date
    Jan 2010
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    depends what pump they put on mate was it the updated 1? best bet is to get it on a code reader see what shows up

  5. #5
    Regular Member
    Join Date
    Dec 2008
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it was the upgraded pump,looks like a trip to vx cheers anyway mate

  6. #6
    Regular Member hoochydady's Avatar
    Join Date
    Jan 2010
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    fire a help any 1 got op-com near me thread up mate may save you a trip to the dealers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. loss of power
    By STRETCH2009. in forum Engine & Drivetrain
    Replies: 6
    Last Post: 8th August 2012, 18:44
  3. Power loss HELP
    By dezzyb66 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 28th July 2012, 12:34
  4. 2L DTI '53 Loss of Power
    By BigTunz in forum Engine & Drivetrain
    Replies: 17
    Last Post: 3rd November 2011, 17:27
  5. loss of power
    By philly in forum Engine & Drivetrain
    Replies: 11
    Last Post: 11th May 2009, 07:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •