User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Horn constantly going off and Raido control

  1. #1
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default Horn constantly going off and Raido control

    So - posting this for chrisvectra as he is at work.... He has a problem:

    Driving to work the horn started to go off. When he got to work, removed the keys and it was still going off to disconnected the battery.
    So - he has checked the steering wheel wiring etc, and has found that if he disconnects the right steering wheel control (volume scrolly) the horn would stop going off.. But the horn will then not work at all even when pressing the horn.

    Before he disconnected the right steering wheel control - the stereo will skip CD tracks and raido will automatically change stations (so the buttons on the control are doing there own thing!)


    I think it sounds like that right hand steering control is shorting / failing somehow causing the horn to activate, and adjust the stereo etc..

    With this disconnected the Stereo is fine - just no horn at all (but that may be normal)

    Thoughts??

    Cheers Ant

  2. #2
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    no one got any ideas
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  3. #3
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    .... so bit of an update:

    Chris came to me last night and we did some work / testing / and in the end sorted (we think) the problem.

    So - the issue was that with the volume steering wheel control connected to the loom, and the two earth spades connected to the Metal horn plate (the full metal plate behind the airbag), as soon as you connected the volume steering control the horn activated... AND this happened when the horn plate was awar from the wheel.

    So - what we did to fix it was connected one of the two earth spades from the volume control to the big horn metal plate and the other to the black horn plate behind the big metal plate..
    This resolved the issue and the horn works, as well as the Radio volume control..


    What would be very hand please is for someone who has a facelift wheel, can you explain where the two earth points are connected two on your wheel to see what is the actual correct way...

  4. #4
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    pics please pretty please
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Air con hissing constantly after re-gas
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 25
    Last Post: 3rd July 2012, 13:22
  2. Heater constantly hot. Help?
    By Critch in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 8th October 2011, 11:28
  3. Heater constantly blowing hot!!!!!
    By axelf in forum Engine & Drivetrain
    Replies: 6
    Last Post: 29th March 2011, 16:44
  4. Internal Fan / Heater Constantly on !
    By avitohyes in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 4th June 2009, 21:36
  5. Radiator fan is constantly on, anyone help?
    By fuzzbomUK in forum Engine & Drivetrain
    Replies: 8
    Last Post: 29th November 2008, 18:46

Visitors found this page by searching for:

vectra horn on constantly

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •