User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Alternator or CIM

  1. #1
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Alternator or CIM

    Hello everyone, this morning on school run, my car went berserk, when I started it up, I noticed the dash and display dimming slightly more than usual, but put it down to being a cold morning, then 10 mins away from home jammed in traffic, the dash, info display and all lights started flashing on and off, but only when I reved the engine up to drive, when idling everything was fine. Also the overload relay behind the glovebox was clicking on and off
    First thought was oh my god, the CIM has gone, but when I got home, I checked the voltage on the battery and got the following :

    Engine Off in Sleep mode : 12.7v
    Engine idling : 13.8v
    Engine reved to constant 1000rpm : 11.2v to 16.9v (hunting up and down)

    To me it sounds like the voltage regulator has gone on the alternator and the spike in voltage is causing the overload relay to trip, what do you guys think please?

    Thanks John

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Your diagnostic sounds correct.

    The alternator shouldn't be putting that much voltage out no matter what.

  3. #3
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Phew thank god for that... now a trip to fleabay!. Out of interest, does any veccy C alternator fit or ire they all specific to enging besides the amp output?

  4. #4
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    It could be a 100 or 120 amp mate. Do the two halfs interlock or just line up next to each other, I take it you have s 1.8 or 2.2 petrol?

  5. #5
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its a 2.2 mate, and is the 100amp version, just wondering if just replacing the voltage regulator would be best, or just gamble on a complete 2nd hand unit.

  6. #6
    Regular Member yysnet's Avatar
    Join Date
    Jul 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you measure the voltage by DIREDTLY probed to the battery electrode?
    Or to the connector nearby?

    It's not normal for a battery voltage rised to 17V and dropped to 11v.

    Your diagnostic is sound right, but i would check the battery and connection first.

  7. #7
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    OMG just tried to get the alternator out, all fine until the last bottom centre bracket bolt, cant get a spanner or socket onto it because of the flippin air con pipes in the way, whoever designed this engine needs my breaker bar wrapping around his neck. Checked all the connections around it, everything sound, Anyway, grazed nuckles and a bad back later I put it all back together and started it up, all seemed fine until about 10 mins later then it went nuts again. I'm gonna go and cry in the corner now.

  8. #8
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by yysnet View Post
    Did you measure the voltage by DIREDTLY probed to the battery electrode?
    Or to the connector nearby?

    It's not normal for a battery voltage rised to 17V and dropped to 11v.

    Your diagnostic is sound right, but i would check the battery and connection first.
    Yes mate on the battery itself, connected op-com too to watch the system voltage, and that shows similar fluctuations, plus fault code for overload relay and no communication to CIM.

  9. #9
    Regular Member yysnet's Avatar
    Join Date
    Jul 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Bless, GM is really a bad design. you have to go down the car like a rat for a oil filter change.

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by yysnet View Post
    you have to go down the car like a rat for a oil filter change.
    Eh? The filter change is probably the easiest I've come across on any car. Pop the hud, and there it is facing upwards towards you.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Alternator
    By Marky in forum Electrical & ICE (including SatNav)
    Replies: 19
    Last Post: 19th March 2012, 00:50
  2. which alternator
    By john1 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 22nd December 2011, 13:32
  3. Alternator
    By m8wos in forum Engine & Drivetrain
    Replies: 31
    Last Post: 10th December 2011, 20:54
  4. what alternator do i need?
    By Mads in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 4th December 2011, 14:50
  5. alternator
    By hitcho in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 17th October 2010, 21:01

Visitors found this page by searching for:

vectra c 13.8 alternator voltage

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •