User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Steering VERY light at speed!

  1. #1
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Steering VERY light at speed!

    Hi All,
    Yesterday night driving home down the M1 I decided to 'make up' a bit of time I lost in the roadworks, car felt and drove fine, actually quite impressive pull for a 2.2 petrol at high speed (shame the take-off isn't any good from stand still), anyway, the only thing that made me think oooo eeeee was the steering, everytime I went over 85mph the steering just felt like the wheels weren't attached to the road anymore, and the steering went incredibly 'light' until I slowed down below 85mph again.
    I've had cars with electronic speed sensitive steering before, but that was just crazy, is that a sign my pump is gonna conk out or is it normal?
    Steering is fine at normal speeds, wheels and tyres are perfectly balanced, no vibration.....

    04 (53) 2.2 SRi Petrol by the way with standard 17" SRi alloys.

    Thanky

  2. #2
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Are your tyre pressures ok?

  3. #3
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah tyre pressures are fine, always check them before a long journey ever since my hum dinger a couple of years ago... lost my beloved Omega MV6 and nearly myself due to blow out on motorway because I had a 'saggy' tyre lol
    Laugh now but wasnt funny at the time, and I still miss that car :-(

  4. #4
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    did you get any vibration at all that was out of the normal?

  5. #5
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nothing that made me aware, and I havent heard any clunks or clonks, steering is still tight too, no play.
    Another thing I have just noticed coming back from school run, is that my dash and info display isn'y dimming up and down, it usually does when I steer, but again steering still feels perfectly normal driving at regular speeds. Wierd, but I suppose if it aint broke, dont fix it.

  6. #6
    Regular Member kamar's Avatar
    Join Date
    Jul 2007
    Location
    bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine is quite tight at high speed but on my previous car honda dealers told me as u go faster the stering gets stiffer...

  7. #7
    Regular Member Jekyll & Hyde's Avatar
    Join Date
    Sep 2007
    Location
    Walderslade Woods,Kent.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Is the rubber splitter still on the very bottom of the bumper?

  8. #8
    Regular Member johnnyallen's Avatar
    Join Date
    Feb 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi mate, yes it is, got underneath it last night, nothing else seems loose or missing, but got a new problem developed this morning which I'll post in the electrical side of forum, coud be related possibly.
    Thanks for the help guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering rack speed sensor
    By John LE in forum Suspension, Wheels & Brakes
    Replies: 14
    Last Post: 10th October 2011, 23:19
  2. Power steering - disable in high speed
    By zafira in forum Suspension, Wheels & Brakes
    Replies: 4
    Last Post: 10th August 2011, 01:25
  3. Steering feels light at motorway speed
    By philgst in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 26th October 2010, 17:28
  4. steering wheel judder when at higher speed
    By bunsen1 in forum Suspension, Wheels & Brakes
    Replies: 17
    Last Post: 29th August 2010, 15:36
  5. Noisely steering at slow speed
    By janc in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 21st January 2008, 13:56

Visitors found this page by searching for:

vecyra c steering play high speed

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •