User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 1.9 cdti 120 difficult to start and low power under 1500 revs

  1. #1
    New Member
    Join Date
    Jan 2010
    Location
    Gateshead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.9 cdti 120 difficult to start and low power under 1500 revs

    Hello, looking for some help, my 120 CDTi is taking a little longer to start than usual, it is also lacks power under 1500 revs, i have seen lots of advice about EGR valves but as this is my first diesel would like some experienced advice. The car has 89k on it and was serviced 8k ago. The Car is a 2006 facelift model.

  2. #2
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Longer starting issue might be the glow plugs on the way out, but having said that, diesel's do seem to take a little longer to start as the colder mornings hit. Try letting the glow plug light go out then switch off ignition, without starting the car, then ign on and let the light go out a second time, then start, see how that performs.
    Egr valves can be troublesome, but first, check all the small vacuum hoses for splits, as these control the turbo boost.

  3. #3
    New Member
    Join Date
    Jan 2010
    Location
    Gateshead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Many thanks for the quick reply, i will check the Glow plugs this week and all the hoses, i have started to leave until all lights go out but some times still takes a while. will let you know how i get on, is it best to get genuine or OE glow plugs.

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the classic EGR valve prob. Bet it's jerking a bit when driving on small thottle positions too?

  5. #5
    Regular Member
    Join Date
    Oct 2009
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Probably not the glow plugs, they only operate below approx. 6C.

  6. #6
    New Member
    Join Date
    Jan 2010
    Location
    Gateshead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    not jerky, quite powerful still above 1500, just need to drop down a gear when below.

  7. #7
    Regular Member
    Join Date
    Oct 2009
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    So not jerking when holding 30mph in 4th then?

  8. #8
    New Member
    Join Date
    Jan 2010
    Location
    Gateshead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not jerking when 30 in 5th, thats the surprising thing, it is literally when in second and below 1500 rev got to drop down or wait until it catches up, it could be me going from petrol to diesel.

  9. #9
    Regular Member
    Join Date
    Oct 2009
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah probably! It's not on the boost fully until 1.5k rpm

  10. #10
    New Member
    Join Date
    Jan 2010
    Location
    Gateshead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That explains it then, thanks will have a look at the glow plugs and let you know, cheers

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No power in low revs vecrta 1.9 cdti sri
    By vectra19 in forum Diesel Engine related
    Replies: 4
    Last Post: 11th July 2012, 17:22
  2. CDTI 120 difficult to start
    By matt_harw in forum Engine & Drivetrain
    Replies: 31
    Last Post: 14th November 2011, 21:48
  3. Hestitation between 1500 and 2500 revs
    By Marky in forum Engine & Drivetrain
    Replies: 31
    Last Post: 12th May 2011, 20:36
  4. no power at low revs cdti
    By brownlow39 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd May 2010, 19:39
  5. 1.9 cdti power loss at low revs
    By topdogs in forum Engine & Drivetrain
    Replies: 14
    Last Post: 27th January 2008, 03:56

Visitors found this page by searching for:

1500 revs

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •