User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Heater blower thread 233453#

  1. #1
    New Member
    Join Date
    Sep 2010
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater blower thread 233453#

    Help needed!

    Picked up my 2003 LS Vectra a couple of weeks ago, water in passenger footwell and heater only working on number 4 setting. Dried out carpets, cleared drainage holes and replaced the resistor pack.

    Worked great for a couple of days, tonight jumped in car and the heater blower now only working again on 4th setting.

    Help!!!!!!!

    Leggy

  2. #2
    Regular Member Keithy's Avatar
    Join Date
    Jan 2008
    Location
    Dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I would try fitting a new resistor first mate

  3. #3
    New Member
    Join Date
    Sep 2010
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I did....last week, worked fine until tonight!

  4. #4
    Regular Member Keithy's Avatar
    Join Date
    Jan 2008
    Location
    Dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Then it sounds like your gonna need a whole new motor mate. The water entering your car would have had a part to play in this

  5. #5
    New Member
    Join Date
    Sep 2010
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Oh great!!! Dried out the car for a week before replace the resistor pack, thinking that be enough. So even though heater works on 4th setting it still needs replaced? Anybody got a link to the 'how to replace blower motor?!'

    Thanks for replies

    Leggy

  6. #6
    Regular Member Keithy's Avatar
    Join Date
    Jan 2008
    Location
    Dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i think the resistance caused due to the motor shaft corroding has gubbed your new resistor. I may be wrong though

  7. #7
    Regular Member benwalters82's Avatar
    Join Date
    Nov 2009
    Location
    Redruth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.0DTI

    Year : 2002

    Default

    try some oil on the blower spindle first (through the pollen filter). Worth a try before forking out on a motor.

    There is a cheap Maplins fix for the resistor.

  8. #8
    New Member
    Join Date
    Sep 2010
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks guys, I'll have a look over the weekend. This 2nd car wasn't meant to cost me any money!!!

    Had a look on eBay, £60-£90 for a replacement heater blower motor. Any breakers/ diplomats provide for less? Based in Glasgow

    Leggy

  9. #9
    Regular Member
    Join Date
    Sep 2008
    Location
    playing with spanners
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i had the same problem, had to replace the motor, payed about 90 for mine on ebay and got the resister with it too

  10. #10
    Regular Member djr69uk's Avatar
    Join Date
    Feb 2008
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    this thread might help - there are other things to check

    http://www.vectra-c.com/forum/showthread.php?t=56294

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Heater / Blower Fan
    By chris2464 in forum Bodywork & Interior
    Replies: 3
    Last Post: 5th January 2012, 13:30
  2. heater blower
    By bootneck85 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 18th April 2011, 00:40
  3. Heater blower!!!!!
    By mitch in forum Electrical & ICE (including SatNav)
    Replies: 14
    Last Post: 19th November 2010, 00:15
  4. heater blower
    By Pete Kincaid in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 11th January 2010, 21:58
  5. Heater Blower
    By Woolly in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 26th July 2008, 18:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •