User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Help Needed - 1.8 Vectra in Limp Mode

  1. #1
    Regular Member Kyser143's Avatar
    Join Date
    Apr 2007
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help Needed - 1.8 Vectra in Limp Mode

    My car was working perfect a few days ago until it went in to a garage for some winter fixes. I have had coolant leak for a while now due to expansion tank cracked, Gave it to a garage to put in a new expansion tank and fill coolant ready for winter. I get call its done and since then the warning light has been on didnt notice anything until day after when its in limp mode and engine is shaking more than usual.

    Got a mate to put on a diagnostic and it shows crankshaft sensor and misfire on cylinder one. The guy replaces the crankshaft sensor still the same then changed the plugs still no better. Changed coilpack and still no better. Checked the spark from each cylinder and cylinder 1 def has no spark so suggest a wiring fault. Anyone experiences on here able to suggest anything else or does a wiring fault seem the only answer. Its a 1.8 petrol lpg vectra by the way.

  2. #2
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    Why not go back to the garage that worked on your car and tell them what you have just told us,if they caused the problem it's up to them to put it right

  3. #3
    Regular Member Kyser143's Avatar
    Join Date
    Apr 2007
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jonnybravo View Post
    Why not go back to the garage that worked on your car and tell them what you have just told us,if they caused the problem it's up to them to put it right
    Easier said than done I got told sorry we only worked on the expansion tank also got no code reader. Not much help and won't be used by me again

  4. #4
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    take it to the dealers best help incase serious

  5. #5
    Regular Member Kyser143's Avatar
    Join Date
    Apr 2007
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok an update my neighbour know a mechanic working on the police cars he brought out a tech 2 and suggested doing a compression test which came out fine. Checked plugs and cylinder 1 plug is as new as when it was put in so basically cylinder 1 ain't firing what could be stopping this . is it likely wiring issue was suggested it could be the ECU any thoughts of why cylinder 1 won't fire tried a new coil pack

  6. #6
    Regular Member Kyser143's Avatar
    Join Date
    Apr 2007
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thought I would give a final on this might help someone. The fault was investigated by Vx and after £158 of diagnostic they said its a wiring fault and as its Dual fuel there is a problem in the wiring loom going to ECU and they cant do anything about it as they dont make the looms anymore.

    So suggested a auto electrician, Got one of them to have a look and after check lots of wires it was the ECU not sending a signal from the lpg loom for cylinder 1 so the auto elec by passed the ECU and all working now. Saved me replacing the ECU.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra 2.2 SRi (22se) EML on limp home mode
    By james chambers in forum Engine & Drivetrain
    Replies: 2
    Last Post: 4th November 2012, 20:52
  2. 2006 Vectra In Limp Mode
    By PAULJG in forum Vectra C / Signum Troubleshooting
    Replies: 9
    Last Post: 7th February 2011, 21:43
  3. 2.0 DTi 03 Vectra - Limp Mode - Help!!
    By scrumpycider in forum Engine & Drivetrain
    Replies: 8
    Last Post: 26th August 2009, 21:57
  4. unhappy vectra c keeps going into limp home mode
    By discojohn in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 20th June 2009, 00:37
  5. help limp mode on vectra 1.9cdti
    By signum junkie in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 27th April 2008, 22:38

Visitors found this page by searching for:

vectra limp mode

vectra c 1.8 limp mode

vectra sri in limp mode

vauxhall vectra 1.8 limp mode

vectra 1.8 crank sensor cause limp mode

take vauxhall vectra out of limp mode

vectra c limp mode reset

limp mode opel vectra

1.8 vectra in limp mode then ok

Opel vectra in limp mode

vectra c limp home reset

vectra in limp mode

vauxhall vectra c 1.8 ls limp mode

vauxhall vectra limp mode

vectra limp mode added fuel worked

vectra 1.8 in limp mode

vauxhall zafira 1.8 petrol auto keeps go limp mode

vectra gone into limp mode

vauxhall vectra in limp mode

vectra c no spark

vectra c limp mode

53 reg 1.8 vauxhall vectra limp mode

vectra c in limp mode

03 vectra in limp mode

vectra c engine 1.8 limp mode

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •