User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: veccy sluggish?

  1. #1
    Regular Member ilovetechno's Avatar
    Join Date
    Sep 2010
    Location
    Corby/Portugal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default veccy sluggish?

    Hi,today i had my vectra 2.0 turbo serviced, i bought the car last saturday and between gears i could fell the turbo kicking in @ about 3000 rpm, but after the service i took it for a spin and it feels a bit sluggish not the same kick from the turbo.

    Is this normal should i give it few more miles for oil to run tru the car?

    Any advice or help welcome.

    Thanks in advance!

  2. #2
    Regular Member mann3210's Avatar
    Join Date
    Mar 2009
    Location
    scotland, perth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i just had the same problem with my 2.0T, i got it servied about 2500 miles ago, what i did notice was i hadnt driven it hard in a long time, i drive like 6miles a day not goin over 40mph but the other day a got the chance to go out 4a blast, i took it up the motorway & givin it a bit of a boot it seemed like it was a new engine again after a couple minutes of fun!!!

  3. #3
    Regular Member ilovetechno's Avatar
    Join Date
    Sep 2010
    Location
    Corby/Portugal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks mate , same here only do about 3-4 miles a day @ 40-50mph , so will take her for a proper spin 2mora.

  4. #4
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Or it could be because of a cheap and restrictive air filter and poor quality oil.

  5. #5
    Regular Member ilovetechno's Avatar
    Join Date
    Sep 2010
    Location
    Corby/Portugal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    just an update , car seems to go back to her normal state of mind

  6. #6
    Regular Member
    Join Date
    Sep 2009
    Location
    Slovenia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what did you do then? A heavy "treatment" on the motorway ?

  7. #7
    VIP-Member GSiFan's Avatar
    Join Date
    Nov 2006
    Location
    Houghton Regis, Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : GSi

    Engine : 3.2 V6

    Year : 2003

    Mileage : 202,000

    Default

    My GSi feels much stronger following the fitment of a replacement mass air flow sensor. I had a dashboard warning that something was amiss, so replaced the MAF. The warning remained for almost a week... then vanished and the car was transformed! It is a joy to drive again and the engine has its "power everywhere" character back.

    I am running the stock air filter, which is overdue a change, actually and 5W30 fully synthetic oil.

    Paul
    2003 Vauxhall Vectra GSi 3.2 V6

  8. #8
    Regular Member ilovetechno's Avatar
    Join Date
    Sep 2010
    Location
    Corby/Portugal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by buggy View Post
    what did you do then? A heavy "treatment" on the motorway ?
    Yep

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 SRi Sluggish
    By obews in forum Engine & Drivetrain
    Replies: 15
    Last Post: 2nd November 2012, 20:30
  2. sluggish
    By iokarus in forum Engine & Drivetrain
    Replies: 8
    Last Post: 29th February 2012, 20:35
  3. Sluggish again
    By durham4416 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 7th February 2011, 18:20
  4. sluggish
    By chrosty in forum Diesel Engine related
    Replies: 13
    Last Post: 29th December 2010, 23:55
  5. sluggish 1.9 cdt
    By thommo in forum Introduce yourself.
    Replies: 3
    Last Post: 16th March 2010, 14:57

Visitors found this page by searching for:

vectra c 3.2 sluggish

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •