User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Red airbag Light

  1. #1
    New Member
    Join Date
    Oct 2007
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Red airbag Light

    When returning from shopping I went to start the car (2.0 DTI) and nothing happened. A red airbag (or seatbelt tensioner) icon is flashing on the dash along with a yellow power steering icon. Would either of these faults stop the car from starting? Had to call the recovery guy out. He didnt know what was causing it either. We tried bump starting the car but no joy. The car has been towed to the garage awaiting Monday morning when it opens. Any advice would be appreciated.

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Did the engine turn over at all?

    Did the breakdown guy check for a flat battery, or poor earth connection?

  3. #3
    New Member
    Join Date
    Oct 2007
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No the car did not turn over. The breakdown man did put a battery pack and tried to start it but nothing happened. We also tried to bump start it but again no joy. I dont think he checked the earth.

  4. #4
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check all youf fuses too.

    then get a code reader and get back to us with fault codes

  5. #5
    New Member
    Join Date
    Oct 2007
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just been to the car. I plugged in a ELM327 reader but it said there was no data/no response form the car. I've used this before to reset the EGR fault codes so I know it works. I've noticed now the radio display is cycling through 'code' and normal operation. This wasn't happening yesterday. All the lights on the dash were slightly flickering so I switched on the sidelights and the dash lights went all dim (virtually off). I switched off the sidelights and the dash lights came back. Seems like the battery is dying. Also the car wouldn't lock properly with the fob. All the doors except the drivers would lock or the drivers would lock and the others wouldn't. I tried with the key in the door lock and the same happened. Ended up physically locking the doors individually from the inside without the key/fob. The garage opens tomorrow so hopefully they'll work out what's wrong. I'll keep you posted.

  6. #6
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    could be the abs plug causing can bus signal trouble. dissconect the battery give the plug a shack and wait 10-15 mins probably go

  7. #7
    New Member
    Join Date
    Oct 2007
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Got the car back today. Garage said the starter motor was sticking. They released it and it worked fine. They said they tested it throughout the day and it started fine. They told me it may need replacing but to see how it goes. All the warning lights have gone too. Strange that a sticky starter motor would have set them off? I do recall the recovery guy was going to give the starter a whack. He had a look but the heatshield was in the way.

  8. #8
    Regular Member
    Join Date
    Jun 2010
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I need some help my airbag lamp came on this morning , I have a code reader but it will only read engine codes, any ideas of potential causes before I take it to have the codes read its a 2003 2.2 sri any ideas greatly appreciated

  9. #9
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Normally the plugs under the front seats get knocked. Check those first imo.
    Now I need a turbo to keep up!

  10. #10
    Regular Member
    Join Date
    Jun 2010
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for the reply I will check them, I was going to disconnect and reconnect , any moer experience of airbag lamps and causes would be appreciated

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airbag light!
    By joee91 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 25th June 2012, 01:52
  2. Airbag light
    By Sharpy28 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 12th June 2012, 22:26
  3. AIRBAG light .. is thier a fuse the the Airbag ecu ?
    By Steven T Davies-Moss in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 10th September 2011, 13:21
  4. Airbag Light
    By rocket999 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 18th August 2011, 16:22
  5. Airbag Light
    By Hollingsworth87 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 16th April 2011, 16:29

Visitors found this page by searching for:

vectra 2.2 dti air bag light

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •