User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: cruise control not working

  1. #1
    Regular Member VECTRA HEAD's Avatar
    Join Date
    Feb 2008
    Location
    Derry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default cruise control not working

    A few days ago i got a code read on my 02 dti vectra,it was related to a switch on my clutch pedal,i thought that this was the reason that my cc wasn`t working.Today i got a garage to fit the switch but the cc still isn`t working..Has anyone got any ideas on what to try now to get the cc working again?Thanx in advance

  2. #2
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    Could be the contacts in the stalk, or a faulty stalk?

  3. #3
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    The clutch return spring might need replacing. Try lifting the clutch pedal up with your foot and see if the CC works then, the switch on the end of the stalk might need cleaning.

  4. #4
    Regular Member VECTRA HEAD's Avatar
    Join Date
    Feb 2008
    Location
    Derry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    any tips on cleaning the stalk Ed?is there a switch on the brake pedal that would interfere with the cc?

  5. #5
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    There is a return spring they goes weak and doesn,t return the pedel back to the correct position. There must be a switch, as when you touch the clutch pedel the CC disengages.

  6. #6
    Regular Member VECTRA HEAD's Avatar
    Join Date
    Feb 2008
    Location
    Derry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I know what ur saying Ed but i have already replaced the clutch switch,is it hard to remove the stalk as i might replace it?

  7. #7
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Quote Originally Posted by ed taylor View Post
    The clutch return spring might need replacing. Try lifting the clutch pedal up with your foot and see if the CC works then,
    Have you tried that yet VECTRA HEAD?

  8. #8
    Regular Member VECTRA HEAD's Avatar
    Join Date
    Feb 2008
    Location
    Derry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No i haven`t got a chance yet,my wife has the car at work today

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cruise control not working
    By bigsteve3.0v6 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 9th October 2011, 21:53
  2. Cruise Control not working :(
    By Princess D in forum Vectra C / Signum Troubleshooting
    Replies: 38
    Last Post: 14th January 2011, 16:16
  3. Cruise Control - working again!!?
    By djr69uk in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 30th March 2009, 19:30
  4. Cruise Control not working
    By jonnyc in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 21st December 2007, 04:53
  5. Cruise control not working
    By armoured farmer in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 6th August 2006, 21:07

Visitors found this page by searching for:

Cruise control not working on my Vauxhall zafira

vectra c cruse control not working

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •