User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: coilpack = fault code?

  1. #1
    Regular Member
    Join Date
    Dec 2009
    Location
    north wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused coilpack = fault code?

    just wondering if a failed coilpack will show up a fault code?
    I've got a 3.2 v6 that judders, only under acceleration, similar to a wheel out of balance and can't figure the cause!
    I didn't think it was a misfire because it seems speed related, starts at about 50mph and eases off about 70mph. (i did start another thread about this but it disappeared )
    I've had the car on tech2 and no fault codes are present.
    wheels balenced twice, no noise from wheel bearings, swapped wheels front to back too.
    I've also swapped rear bank coilpack for a second hand spare that I had, problem exactly the same.
    any ideas/help appreciated!

  2. #2
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah it should throw up a misfire fault code for the affected cylinders, seeing as it isn't misfiring have you considered changing the plugs? Or at least whipping them out to have a look at their condition.

  3. #3
    Regular Member
    Join Date
    Dec 2009
    Location
    north wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    oooh, forgot to say, I've changed the plugs too!
    so i would get the car/spanner light if the coilpack had gone?

  4. #4
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The only thing I can suggest is try that speed range in different gears so its at different revs and see if the judder is still apparent, if so its nothing to do with the engine and probably wheels out of balance, warped brake discs, steering rack arms or suspension bushes/ball joints.

  5. #5
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    as above need to see if its engine speed or vehicle speed as could be driveshaft

  6. #6
    Regular Member
    Join Date
    Dec 2009
    Location
    north wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for the ideas!
    I've also just put new front discs and pads on as the old ones were rotten, (thought it may affect the balance ......somehow!) made no difference either!
    The thing that makes me think it's engine related is that if you accelerate gently you can barely notice it, it's only if you floor it or going up hill you really feel it, and it stops if you take your foot off the gas.
    When i changed the plugs all 6 looked the same too, ie not 1 odd sooty one.

  7. #7
    Regular Member hoochydady's Avatar
    Join Date
    Jan 2010
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    have u changed the fuel filter and is the injectors clean ? could it be fuel related what about puting a injector cleaner throu the system see if it helps it

  8. #8
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    On the 2.5 V6, the coil pack often doesn't create a fault code when it fails, even if the engine's down to 4 cylinders, so could be the same on the 3.2

  9. #9
    Regular Member
    Join Date
    Dec 2009
    Location
    north wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hmmm, it's just one coilpack for all 6 plugs on the 2.5 isn't it? Wonder if it would do the same?
    Is there anyway of checking them or is it just a case of splashing out on a new one?
    be just my luck that the front one has gone as it's a spare rear one i've got!
    could be fuel related too though....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Coilpack Testing
    By spoons in forum Engine & Drivetrain
    Replies: 19
    Last Post: 23rd August 2012, 09:31
  2. coilpack
    By Morephun in forum Engine & Drivetrain
    Replies: 3
    Last Post: 9th October 2008, 07:57
  3. fault code help
    By tankman in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 21st March 2008, 11:07
  4. Fault code ID
    By Jamesdti in forum Engine & Drivetrain
    Replies: 8
    Last Post: 21st March 2008, 04:24

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •