User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: spanner light on after engine service

  1. #1
    New Member
    Join Date
    Jul 2010
    Location
    radcliffe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default spanner light on after engine service

    was wondering if anyone could shed a little light on what i have done to make my spanner light come on.....
    i serviced my car last week used all proper GM oil and filters, put correct oil level in changed diesel filter etc etc.....now when u start my car the spanner light comes on for 2 seconds then goes out and does not come on till i restart the car and this happens everytime, is there some way of turning it off i do i have to have it reset at vx...cheers dave

  2. #2
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Is this the car and spanner light or the oil can and spanner light??

  3. #3
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    Thats wiered that
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  4. #4
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    does the INSP code still come up on the odometer when you turn her on?


  5. #5
    Regular Member Rapala's Avatar
    Join Date
    Oct 2008
    Location
    Clackmannanshire Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its showing you that a fault has been present and has now cleared itself (did you have the ignition on at any time during the service with any of the electrics unplugged?). The light will stop coming on after 20-30 clean starts if no other fault occurs.

  6. #6
    New Member
    Join Date
    Jul 2010
    Location
    radcliffe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    no the ignition was not on at any time neither is the oil can light it is just a yellow car symbol with a spanner through it....no insp light either and it is only on for a few seconds then goes out and does not come on till i start the car again

  7. #7
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    service is likely red herring now i come to think of it

    how about glow plugs?

    i'd guess with colder mornings now's the time they'd start showing a fault...

  8. #8
    Regular Member Rapala's Avatar
    Join Date
    Oct 2008
    Location
    Clackmannanshire Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    A glow plug going faulty would normally put the spanner light on for a couple of minutes or so at the first start of the day, not a couple of seconds though.

  9. #9
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes it is usually a few mins for glow plugs but i''m trying to think logically ......and struggling to think now what else might be the cause

    I assume this light is on once you've fired it up? are there any other lights on at the time?

  10. #10
    New Member
    Join Date
    Jul 2010
    Location
    radcliffe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    no more warning lights on dash.......the glow plugs seem to be ok as it starts first time, must of started it 50 times this week and still the light comes on....weird

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  3. loss of power / service spanner light
    By cookie01 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 9th August 2011, 11:11
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light on after service.
    By zeadly in forum Engine & Drivetrain
    Replies: 20
    Last Post: 31st July 2007, 16:05

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •