User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: EML on and major loss of power

  1. #1
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default EML on and major loss of power

    Hi All,

    Have just joined to see if anyone can help me out with the following problem.

    Ive got a 2003 Vectra 2.2 Dti. For the last few months I've been having a problem with the engine management light coming on and the car going into a 'limp home' mode and losing all power. Very scary situation.

    For the last couple of weeks its been getting more frequent. Turning the ignition off then on clears the light but sometimes it comes on again after a few minutes, other times it doesn't happen for a few days. I've tried cleaning the MAF with isopropyl alcohol but not made any difference.

    Can anybody give me any clues as to what it might be?

    I will try the brake accelerator pedal trick to show fault codes when my wife gets home tonight with the car.

    This problem also occurred about a year ago, we took it in to Vauxhall dealer who read the codes and cleaned the boost sensor. The problem seemed sorted until about 3 months ago.

  2. #2
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    48 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    check boost pipes for splits mate most common is under the plastic cover on top of the engine

  3. #3
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As above and also clean the egr valve and boost sensor - there really common problems on the dti

  4. #4
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    48 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    it most certinaly is

  5. #5
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Thanks for the speedy replies.

    I have checked all hoses and pipes and all appear to be ok. (Although the car has always had a hissing sound when coming off the accelerator)

    Is the boost sensor to the right under the engine cover?

    Can someone tell me where the EGR valve is please? I know its a mucky job cos I have cleaned the one on my mg zt cdti.

  6. #6
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Egr valve how to - http://www.vectra-c.com/forum/showthread.php?t=60856

    Yes the boost sensor is on the right and held on with 1 bolt

  7. #7
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Thanks Dazzy2006. Any recommendations for what to use to clean the boost sensor?

  8. #8
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    48 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    carb cleaner or alchol be carefull though its very delicate

  9. #9
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    carb cleaner and soft toothbrush


  10. #10
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What they both said apart from theres no way on earth im using alcohol on mine - i'd rather drink it thanks paul

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Major loss of power
    By WeDesign in forum Engine & Drivetrain
    Replies: 130
    Last Post: 17th September 2012, 13:51
  2. major power loss and engine noise
    By martin.lake in forum Engine & Drivetrain
    Replies: 2
    Last Post: 17th September 2012, 00:13
  3. 1.9CDTi Major Power Loss
    By GlennM in forum Engine & Drivetrain
    Replies: 23
    Last Post: 22nd May 2010, 21:59
  4. Major loss of power
    By martinmack in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 7th November 2009, 18:58
  5. No power after major problems
    By adam3682 in forum Vectra C / Signum Troubleshooting
    Replies: 14
    Last Post: 4th August 2009, 15:16

Visitors found this page by searching for:

vectra c 1.9 eml no power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •