User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: can any1 help im at my witts end with my veccy 2.2 04

  1. #1
    Regular Member
    Join Date
    Aug 2010
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default can any1 help im at my witts end with my veccy 2.2 04

    hi there people ,

    can anyone help me im ripping my hair out my veccy 2.2 direct 2004 is realy poorly. the tick over is up and down and sometimes cuts out when clutch is pressed in on approach to lights. and when i accelerate harsh is hesitates and also when i put more than 9/10 liters of fuel in spanner light appears till i restart car again.could the sensor connected to the intank pump cause these issues or fauly co2 sensor. ive unplugged air flow sensor still the same it has also had new fuel regulator under a recall a frw week ago any1 any ideas im at my witts end with this car...

  2. #2
    Regular Member paul wingnut's Avatar
    Join Date
    Mar 2009
    Location
    durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra sri 150


    Engine : 1900 cdti 150

    Year : 2008

    Default

    any t/codes stored have you checked egr on side of head ,throttle body clean?

  3. #3
    Regular Member
    Join Date
    Aug 2010
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi vauxhall woulnt tell me if any codes they said they have done what they had too and is the throttle body which is in front of air box if so then yeah not looked at egr would that cause these faults on 2.2 direct i also fogot to say that when the car is on tick over and i put pedal to carpet it revs to 3000 revs but if i slowly press pedal it revs fine?????

  4. #4
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    High pressure fuel pump mate, the one on the fuel rail.

  5. #5
    Regular Member
    Join Date
    Aug 2010
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    do you think thats 100% rushy ???

  6. #6
    Regular Member
    Join Date
    Aug 2010
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    because its fine when im on motorway sat at 70 ????

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Mate its the main fault on the direct 2.2. They tend to rev fine if your gentle, but when you boot it or the revs start getting higher it goes into limp mode. I take it the pump is a siemens one and not the new continental one? If you do a search on here mate you will find hundreds of threads relating to it. Obviously I cant say its that 100% but it deffo odds on.

  8. #8
    Regular Member
    Join Date
    Aug 2010
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah i understand rushy and yeah its the siemans 1 lol but why in limp home when i fill up ??? and would that answer why tick over is up and down

  9. #9
    Regular Member
    Join Date
    Aug 2010
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    and if i boot it it doesnt go into limp home it just badly hesitates

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Strange then mate, not too sure.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can any1 help
    By bigmansam21 in forum General Chat
    Replies: 4
    Last Post: 13th February 2013, 20:31
  2. any1 seen a white Veccy (feeling a bit lonely)
    By andrewp3883 in forum Vectra C / Signum Car Chat
    Replies: 41
    Last Post: 8th January 2013, 21:09
  3. Replies: 0
    Last Post: 1st October 2012, 17:40
  4. does any1 have.........
    By pokajedi in forum Styling
    Replies: 6
    Last Post: 5th November 2009, 14:41
  5. Does any1 have a part number for veccy c vxr rear bumper insert?
    By vxr in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 28th April 2009, 21:05

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •