User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: gsi service light.......

  1. #1
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default gsi service light.......

    I hold the pedal down while pressing the button the dash, the service light comes on with 21000 underneath but it keeps coming back on.

    anyone know why?

    thanks

  2. #2
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    Indicates service just done, 20,000 miles to next service under ECOFLEX. It is exactly what it is set to in a petrol car under ECOFLEX when the service indicator is reset. Quite normal. It will go down as you rack up the miles, but by more than miles covered if you're not banging up and down the motorway all the time. The Service Due Icon in the rev-counter (car and oil can) will light up when it thinks the next service is due.

  3. #3
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    but it comes back on after a couple of days, even after resetting it???

  4. #4
    Regular Member crespo's Avatar
    Join Date
    Apr 2010
    Location
    Bournemouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Are you sure its the service light (oil can with a spanner through it) not the EML (car with a spanner through it)

  5. #5
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what a dufus, after 9 years of VX ownership you'd think I'd know by now.........lol

    car with a spanner........!!!!

    I'll find out what the code is............lol
    Last edited by david.aka.judas; 12th September 2010 at 12:05.

  6. #6
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    Quote Originally Posted by david.aka.judas View Post
    but it comes back on after a couple of days, even after resetting it???
    It will show 21000 miles with a 'car and oilcan' icon above it in the little window at the foot of the rev counter each time you reset it. The figure should start going down after a few hundred miles. If it is the EML light then the 'car and spanner' icon will appear ON ITS OWN in the same place.

    Although the ECOFLEX service interval for petrols is 20,000 miles, when reset it shows '21,000' as the service indicator will appear with '1000' below it to remind you the service is due.

    It is not unusual on earlier pre-facelifts (up to 04 reg IIRC) for the ECOFLEX Service indicator, with or without a figure underneath it, to appear too early or when it shouldn't. This was a known problem with the software, which can be sorted by a fix at the dealers, but was never seen as a 'driving' problem in itself.

    I had this on both my previous Vectra 'C's (both pre-facelifts) and just kept resetting the indicator.

    If the light keeps coming back of its own accord (i.e. without you pressing the button) then it looks like a software glitch.

    If you get the 'CAR and SPANNER light' then you have a problem reported and stored, and it should be investigated.
    Last edited by john_k_sri; 12th September 2010 at 12:07.

  7. #7
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers everyone - I'll get it looked at.

  8. #8
    Regular Member crespo's Avatar
    Join Date
    Apr 2010
    Location
    Bournemouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by david.aka.judas View Post
    what a dufus, after 9 years of VX ownership you'd think I'd know by now.........lol

    car with a spanner........!!!!

    I'll find out what the code is............lol

    We all make mistakes.
    Its probably just a Lambda sensor on its way out. You will probably get a emision control error. no biggie. Hopefully anyway.

  9. #9
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by crespo View Post
    We all make mistakes.
    Its probably just a Lambda sensor on its way out. You will probably get a emision control error. no biggie. Hopefully anyway.
    you could be right, it running rich atm....

    fingers crossed.....lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 40k mile service and service light
    By a_j_mair in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 31st January 2009, 14:41
  2. service light
    By davidlewis24 in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 9th January 2009, 21:01
  3. Oil Service Light
    By welshy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 24th October 2008, 11:42
  4. service light
    By jaff in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 28th June 2008, 11:02
  5. is there a way to reset service light yourself after a service?
    By EURO G in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 5th January 2008, 00:14

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •