User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: 3.0 V6 auto, am I in limp mode?

  1. #1
    Regular Member
    Join Date
    Nov 2009
    Location
    Hatton, Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 3.0 V6 auto, am I in limp mode?

    Just driven my 04 signum 3.0 auto home and suddenly it "coughed" and the spanner light came on. The rest of the way it seemed as if it was in CVT rather than auto and it wouldn't let me change gears through the manual shift. (it indicated I was in fifth)

    As I pulled away from some lights I realised the car was stuck in fifth so I wrestled with the manual shift a bit and it eventually leapt, with a jolt, down to second. All the rest of the way I could get second or fifth, that was it. Cruise control was also a no-no.

    Is this a gearbox issue? Or textbook limp mode. I can't get it to a dealer until Wednesday, possibly Tuesday, but should I risk driving it or should I summon the RAC to get me there?

  2. #2
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    It would be helpfull if you could read the fault codes, might give some indication.
    Try this it might work on your motor.
    http://www.vectra-c.com/forum/showthread.php?t=81742

  3. #3
    Regular Member
    Join Date
    Nov 2009
    Location
    Hatton, Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for that, tried it a few times but it didn't work unfortunately so I'm still none the wiser.

    I'm not sure what happens when it goes into limp mode, so mainly just trying to differentiate between that and a gearbox problem.

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you only have 2nd and 5th it could be the gearbox in limp mode. You need the codes read to get anywhere.

  5. #5
    Regular Member
    Join Date
    Nov 2009
    Location
    Hatton, Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Will it be wise to drive it the 15 miles to the dealer? Or will I be better calling out the RAC?

  6. #6
    New Member
    Join Date
    Sep 2010
    Location
    belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the same happened to me and i am sorry mate exactly as u explained and i had to have it rebuilt and at the minute it is very bumpy changing from third down to second when i am slowing down to drive over ramps let me know the outcome

  7. #7
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As long as the spanner isn't flashing it's ok to drive carefully for a few miles.
    Now I need a turbo to keep up!

  8. #8
    New Member
    Join Date
    Sep 2010
    Location
    belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default auto box

    Quote Originally Posted by Big Sig View Post
    As long as the spanner isn't flashing it's ok to drive carefully for a few miles.
    im not sure is that me to drive carefully ?? the specialist said i have to let the seals loosen up i reeally havent a clue

  9. #9
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sox View Post
    im not sure is that me to drive carefully ?? the specialist said i have to let the seals loosen up i reeally havent a clue
    Sorry my reply was for the OP
    Now I need a turbo to keep up!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 25th June 2012, 13:36
  2. 3.0 V6 CDTI AUTO - Limp mode, car/spanner warning light
    By Bigv in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 22nd June 2011, 17:51
  3. Limp mode again
    By craig2.2 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 5th August 2009, 21:05
  4. 04 signum 2.2 auto gone into limp mode
    By mikaj in forum Engine & Drivetrain
    Replies: 0
    Last Post: 28th July 2009, 16:15
  5. Limp mode or dead mode
    By JSYSH466Y in forum Engine & Drivetrain
    Replies: 8
    Last Post: 2nd July 2009, 09:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •