User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: EGR Valve issue - 1.9cdti vectra (120bhp)

  1. #1
    Regular Member
    Join Date
    Jul 2010
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default EGR Valve issue - 1.9cdti vectra (120bhp)

    So.....I followed the "How To" on cleaning my EGR valve. The EGR valve, to say the least, was full of crud, substantially worse than the pictures shown on the "How To". The only problem is, once it was re-installed, it worked fine for about five minutes, car was going like the clappers and then it started lagging to the point there was no power up until 2500-3000 revs.
    Im thinking something may have slipped (not sure what there is to slip?) or the EGR valve just needs replacing in its entirety?


    any thoughts would be gratefully appreciated.

    Car is a 2004 1.9 cdti vectra (120bhp)

  2. #2
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hey fellow Brummie ,

    Not sure on the 120 engine, but how was the car performing before the clean out?

    Is it worse?

    Also, re-check the plug, and check all your vacuum hoses, etc.

    When I first did my dads 150 CDTI, it took an age to fire up and when it did it was running like poo and the whole car was wobbling, then eventually after about a minute I managed to get the throttle to respond and it blew out a whole load of cack via the exhaust and ran OK from then.

    I have done an EGR clean out twice and the same thing has happened twice.

    Have you tried taking it for a good blast, right through the rev range in low gears? You might find there is some coke stuck somewhere and just needs a bit of a helping hand to find its way out (watch for the speed cameras though all over Brum).

    Let us know.


    Bye bye Vec B
    - Hello Siggy!

  3. #3
    Regular Member zafira's Avatar
    Join Date
    Aug 2010
    Location
    North of Norway
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You may also clean boost sensor placed in the inlet manifoild. I have 129 engin (8valve) an clean my egr and make a blanking plate with 3 x 4 mm hole in. Its ok now. On 120 the trothle valve also need a clean because the pipe from egr goes in on the manifoild next to this valve. Check also the contact on the egr.

    Good luck

  4. #4
    Regular Member
    Join Date
    Jul 2010
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Car was a bit sluggish before hand, its considerably worse now which makes think something has gone pear shaped. I will attempt to clean the valve later (foudn the how to) however, is it possible that the EGR valve is beyond repair? I dont mind buying a new one however, if its unlikely to fix the issue there is obviosuly not much point in parting with the cash!

    I have booted the car and no sh*te has emerged from the exhaust as yet.

    unsure of "checking contact on egr"?

    any ideas where i can finds the throttle valve as well?

  5. #5
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like its the vacuum pipes?

    Check for holes/splits or that they have not come loose.

    http://www.vectra-c.com/forum/showthread.php?t=109454

  6. #6
    Regular Member
    Join Date
    Jul 2010
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hmm....is it likely I have knocked something then or inadvertantly split a hose? It was workign fine (ish), now its not. Course of action prior to changing EGR for new is clean turno sensor and check (by listening for air?) hoses?

    ****** cars!

  7. #7
    New Member
    Join Date
    Sep 2008
    Location
    Aberdeen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi b,

    had a similar prob on my 150. It took some 3 week after to slove my limp mode and EML fault! told buy my pal that once i cleaned the erg some some gunk would have been left and as the engine gets hot will slowly burn off due to the heat but cause a faulty gas reading!

    also swapped to shell for a couple tanks of shell v power and have had 2k of no issues. Had been in to VX and quoated £800 for new manifold! Not now the problem has self cured!

  8. #8
    Regular Member
    Join Date
    Jul 2010
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have read elsewhere about blanking the EGR off (or restricting it at the very least)? not sure what this does to be honest.

    I will clean sensor and check valves.

    shoudl also add that, prior to be doing the EGR valve clean, the emissions light was on, post clean (and battery off for half and hour) the car was fine until it started going limp and then the car & spanner light came on

  9. #9
    Regular Member
    Join Date
    Jul 2010
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check tubes pipes even

  10. #10
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Quote Originally Posted by baldieone View Post
    I have read elsewhere about blanking the EGR off (or restricting it at the very least)? not sure what this does to be honest.

    I will clean sensor and check valves.

    shoudl also add that, prior to be doing the EGR valve clean, the emissions light was on, post clean (and battery off for half and hour) the car was fine until it started going limp and then the car & spanner light came on
    If you get stuck i have op-com for reading & resetting codes, clean the shaft where it goes through the shroud in witch it travels through.
    http://www.vectra-c.com/forum/showthread.php?t=105853

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. limp mode above 2500rpm Vectra 2006 120bhp 1.9cdti
    By mani911gt3 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd September 2011, 20:07
  2. Vectra 1.9cdti (120) p/steering / alternator issues issue
    By alcutler in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 5th February 2011, 13:18
  3. EGR Valve issue - 1.9cdti vectra (120bhp)
    By baldieone in forum Troubleshooting
    Replies: 0
    Last Post: 10th September 2010, 09:05
  4. Loss of power issue (1.9CDTi SRi 150BHP, Vectra C)
    By Big Sie in forum Engine & Drivetrain
    Replies: 5
    Last Post: 20th April 2010, 17:46
  5. DPF and EGR 1.9CDTI 120BHP
    By robintwall in forum Engine & Drivetrain
    Replies: 1
    Last Post: 13th June 2009, 16:32

Visitors found this page by searching for:

second half egr valve for vectra

2008 cdti vectra egr valve 120 bhp

how 2 clean egr valve vectra c 1.9 8valve

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •