User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: EGR Valve, Engine Management Light & Spanner Light

  1. #1
    New Member
    Join Date
    Jul 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default EGR Valve, Engine Management Light & Spanner Light

    Hello peeps,

    I have removed my EGR valve in order to clean it and then replaced it. I did however make one mistake, when I started it back up I forgot to plug the electrical connector back in, oops. Now I have an engine management light on that just will not go away and I have heard that this is because I turned on the ignition with the disconnected cable. Does anyone know how to reset the light? The spanner light also comes up on startup but then goes away again, I presume that this is because the EM light is on?

    Any thoughts would be greatly appreciated. Cheers.

  2. #2
    Regular Member si_sri's Avatar
    Join Date
    Nov 2009
    Location
    TELFORD
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi,
    try disconnecting the battery for at least 20 mins, this should reset the ecu......
    ensure you have your radio code if applicable...

  3. #3
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Doesnt it automatically reset the light after so many restarts without the fault?

  4. #4
    New Member
    Join Date
    Jul 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by si_sri View Post
    hi,
    try disconnecting the battery for at least 20 mins, this should reset the ecu......
    ensure you have your radio code if applicable...
    I tried this a couple of weeks ago but didnt work unfortunately. If you think the same though it might mean that there is something properly wrong with it that is causing the light to stay on?! Thanks for the response though!

  5. #5
    New Member
    Join Date
    Jul 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Dazzy2006 View Post
    Doesnt it automatically reset the light after so many restarts without the fault?
    Hmm... not sounding good, I made the mistake with the EGR valve about 4 weeks ago now and use my car very regularly. Maybe there is something properly gone wrong then

  6. #6
    Regular Member si_sri's Avatar
    Join Date
    Nov 2009
    Location
    TELFORD
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is the vehicle running ok ?

  7. #7
    New Member
    Join Date
    Jul 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep, the vehicle is running fine!

  8. #8
    Regular Member
    Join Date
    Apr 2010
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It might be worth getting it plugged into a CANBUS code reader to double check there are no other genuine faults - these can reset the warning lights and ecu also, take a look at this:

    http://shop.ebay.co.uk/items/__maxis...=284591_284611

    I'm having a similar issue at the moment and I'm seriously considering buying a decent code reader

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Spanner Light and Engine Management Light
    By Paul_NI in forum Engine & Drivetrain
    Replies: 5
    Last Post: 8th August 2011, 13:42
  3. 'Spanner' engine management light on 2.0Dti
    By Bigdrinks in forum Engine & Drivetrain
    Replies: 2
    Last Post: 14th May 2011, 12:50
  4. EGR Valve/engine management light
    By sleeper341 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd October 2010, 13:07
  5. spanner light then engine management light
    By learoy69 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 12th March 2010, 20:10

Visitors found this page by searching for:

vauxhall vectra engine management ligh egr valvet

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •