User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: dodgy speakers or me?

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default dodgy speakers or me?

    guys i got a pair of vibe 69.3 160W rms, i plugged them into my rubish house sterio to see if they worked, but while testing it i noticed one of the speakers sound deteriorated and the bass went away.

    im guessing either the sterio has no where near enough power for the speakers constantly and thats why its done that, or the speakers have fried?
    whats ur thoughts

  2. #2
    Regular Member
    Join Date
    Oct 2007
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    does your Hfi sound ok on its normal speakers now? Some Hifis don't like the 4 or 2 ohm car speakers....

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeh they are fine..

    i dont understand the ohms thing but im worried the speaker is gubbed tbh, the other speaker on the same speaker port and cabels are much better.

  4. #4
    Regular Member
    Join Date
    May 2009
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    got it going mate, but the bass is kinda crackly which i imagine isnt right and will only get louder with more power.
    kinda gutted

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. seems dodgy to me
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 29th March 2011, 11:17
  2. dodgy MAF
    By craigbarlow18 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 2nd October 2009, 08:29
  3. its gets even more dodgy!!!
    By big rich in forum General Chat
    Replies: 40
    Last Post: 21st August 2009, 19:18
  4. dodgy egr i think!
    By littlesxi in forum Diesel Engine related
    Replies: 12
    Last Post: 21st March 2008, 23:59

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •