User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: vectra 2.2 engine management light

  1. #1
    New Member
    Join Date
    Oct 2009
    Location
    swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra 2.2 engine management light

    whilst driving home from holiday car seemed to hit a flat spot seemed to jump similar feeling to taking off the cruise control this only happened for a split second spanner light came on but car carried on as normal at 70mph for a further 150 miles light goes out when engine restarted any ideas

  2. #2
    Regular Member squekey's Avatar
    Join Date
    Apr 2010
    Location
    bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    not 100% sure mate but could be HP fuel pump or fuel reg as my car does exactly the same thing, its been into vx for the recall on the faulty fuel regulator which has been replaced but car still suffers the judder at 3500 - 4000rpm my eml comes on but car doesnt go into limp mode, light goes off once key has been taken out and car is restarted. vx had the car back done tech2 on it and have said the hp fuel pump is at fault.

  3. #3
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    Might just have been a glitch. Can you get the codes read. Or try the "pedel test". It might work on your motor, then look up the code on the internet.

  4. #4
    Regular Member hoochydady's Avatar
    Join Date
    Jan 2010
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if it happens agian then id say get the codes read or find some 1 local to u that will read the fault codes for ya

  5. #5
    New Member
    Join Date
    Oct 2009
    Location
    swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi sorry not sure what the pedal test is can you give me more info cheers

  6. #6
    Regular Member
    Join Date
    Oct 2008
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite Auto

    Engine : 2.2 Direct Petrol

    Year : 2006

    Default

    Quote Originally Posted by jonahstfc View Post
    whilst driving home from holiday car seemed to hit a flat spot seemed to jump similar feeling to taking off the cruise control this only happened for a split second spanner light came on but car carried on as normal at 70mph for a further 150 miles light goes out when engine restarted any ideas

    Hi...

    Did you ever get to the bottom of this?

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 9-3 Wagon

    Trim : Turbo Edition

    Engine : TID (1.9 16v)

    Year : 2010

    Mileage : 137000

    Default

    Sounds like a glitch if its not happened again but if its a common thing I'd be looking at the HP pump and or Reg on a 2.2 direct.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 54 plate vectra 2.0 DTI engine management light on
    By danny 77 in forum Engine & Drivetrain
    Replies: 20
    Last Post: 22nd January 2013, 18:46
  2. Vectra c engine management light
    By Mark Curran in forum Engine & Drivetrain
    Replies: 4
    Last Post: 16th May 2011, 11:39
  3. Vectra c engine management light on and no power
    By Mark Curran in forum Engine & Drivetrain
    Replies: 6
    Last Post: 13th May 2011, 15:28
  4. Replies: 3
    Last Post: 28th April 2009, 19:49
  5. Vectra B 2.2 SRI DTI Engine Management Light
    By Vaux-Man-G in forum Engine & Drivetrain
    Replies: 9
    Last Post: 10th January 2008, 19:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •