User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: coolant light

  1. #1
    Regular Member
    Join Date
    Feb 2010
    Location
    Aberdeen Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default coolant light

    I have a 3.2 v6 signum. Last weekend I had a motorway journey of about 145 miles. The drive down was fine etc no problems. This was the friday i parked the car up. I then got back to the car on Monday and when I started up the coolant light came on indicating that the water level was low. So I checked the water and it was fine no leakage etc at all. So I drove back the 145 miles and the light stayed on the whole way. The engine temp gauge was acting normal and not overheating. Since then the light is tempermental it will ome on some journeys and other time not at all. Any ideas please I have checked for leaks etc and all the pipes seem good and secure. Thanks.

  2. #2
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Unless there is a fault with the sensor. Can it be removed and cleaned ?.

  3. #3
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Gotta be a sensor throwing a wobbly then (like my technical terms??) see if it can be removed and cleaned up (clean the contacts on both sides of the plug also), if that doesn't cure it you may be looking at a new sensor.

  4. #4
    Regular Member
    Join Date
    Feb 2010
    Location
    Aberdeen Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    any ideas where the sensor is?

  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sat in the header tank I would think as that's where the level is.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. coolant light help.
    By frasedeb in forum Troubleshooting
    Replies: 4
    Last Post: 22nd February 2011, 21:46
  2. Coolant Light
    By kevrod79 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 19th November 2010, 10:56
  3. coolant light on
    By moles-sri in forum Engine & Drivetrain
    Replies: 23
    Last Post: 22nd June 2008, 11:57
  4. low coolant warning light
    By wxmlad in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 16th August 2006, 06:29
  5. Coolant Light
    By bruceybonus in forum Engine & Drivetrain
    Replies: 10
    Last Post: 17th November 2005, 06:25

Visitors found this page by searching for:

rafiator light on on my vectra 08

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •