User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: URGENT - Identification Required

  1. #1
    Regular Member
    Join Date
    Jun 2010
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default URGENT - Identification Required

    Hi all,

    Sorry for the urgent nature of this message, but I'm having engine trouble as detailed here: http://www.vectra-c.com/forum/showthread.php?t=114020 and I'm (supposed) driving the car to Germany on Sunday.

    It has been into the garage for 2 days where they claim to have cleaned the EGR and throttle body, even though I pointed out the parts below as the problem.

    What I need to know is:

    a) What is the part in the red box?
    b) It is controlled by one of the vacuum pumps in the green box (close up in second pic) - WHAT SENSOR(S) CONTROLS THESE?!





    I can swap the vacuum lines and connectors between the pumps and it makes no difference, still get the same problem, so I figure it must be whatever sensor is controlling the vacuum pump and therefore the part in the red box (normally connected to the pump on the right in the photo).

    When the engine starts dropping, I can see the part in the red box pulling all the way in and then it releases as the engine is about to cut out, sometimes not quickly enough and it does cut out.

    I can also simulate the problem if I disconnect the vacuum line and move the level by hand.

    Please help quickly!!

    Adam

  2. #2
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Im taking a guess the engine is a 2.0 dti, in which case your looking in the wrong place you most likely need a new crank shaft sensor.

    Is the fault only happening when hot ? is the radiator light coming on while running if so id say its 90% likely the crank shaft sensor is your fault.

  3. #3
    Regular Member
    Join Date
    Jun 2010
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It's the 2.2 DTI.

    It's sounds the same as post 14 on this thread: http://www.vectra-c.com/forum/showthread.php?t=89343

    Is a throttle body normally held in stock at the dealer or does it have to be ordered?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Urgent help required.
    By floppus in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 3rd April 2012, 11:50
  2. Goodridge hose identification required
    By installer in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 11th March 2011, 21:04
  3. Oh Man, what have I done??? Urgent help required!
    By Nav-Man in forum Petrol Engine related
    Replies: 15
    Last Post: 2nd May 2010, 21:48
  4. Trim Panel Style Identification Required
    By Fireyfella in forum Styling
    Replies: 44
    Last Post: 29th November 2009, 21:37
  5. urgent help required
    By sulky_uk in forum General Chat
    Replies: 15
    Last Post: 22nd February 2007, 18:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •