User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Twang

  1. #1
    Regular Member dominic32's Avatar
    Join Date
    Oct 2007
    Location
    whitstable
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Twang

    Last year just before the mot was due i decided to jack up and have a look, only to find 3 broken springs so i replaced with Spax springs with no problems until i pulled onto my drive today when i heard that twang noise again so i will jack the front up tomorow

  2. #2
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    will be the one spring you didnt change last time .......lol............lol.........lol....

  3. #3
    Regular Member dominic32's Avatar
    Join Date
    Oct 2007
    Location
    whitstable
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i changed all 4

  4. #4
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I had spax and they twanged.

    make they are the right way up, make sure they are seated properly, make sure you used the spring mod sleeves.

  5. #5
    Regular Member dominic32's Avatar
    Join Date
    Oct 2007
    Location
    whitstable
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by david.aka.judas View Post
    I had spax and they twanged.

    make they are the right way up, make sure they are seated properly, make sure you used the spring mod sleeves.
    so spax break as well and they use to be one of the best brands

  6. #6
    Regular Member winnie2457's Avatar
    Join Date
    Dec 2009
    Location
    kings lynn, norfolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Eibach are the way forward superb quality and cost 150 for all 4 springs with next day delivery can't complain

  7. #7
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by dominic32 View Post
    so spax break as well and they use to be one of the best brands
    do you mean twang or twang as is in snap???

  8. #8
    Regular Member dominic32's Avatar
    Join Date
    Oct 2007
    Location
    whitstable
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    it sounded more like the snap twang, they are less than a year old so once i have checked in the morning i will call lmf to see if they will replace

  9. #9
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I bet it hasn't snapped.

  10. #10
    Regular Member dominic32's Avatar
    Join Date
    Oct 2007
    Location
    whitstable
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i am hopeing its not

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kind of a twang!
    By AntSSSS in forum Suspension, Wheels & Brakes
    Replies: 20
    Last Post: 27th April 2012, 20:29
  2. twang twang BANG !
    By gsxrster in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 11th March 2012, 21:27
  3. Twang noise from front?
    By melvin in forum Suspension, Wheels & Brakes
    Replies: 10
    Last Post: 12th December 2010, 12:40
  4. Loud clunk/twang F/N/S
    By speedcat445 in forum Suspension, Wheels & Brakes
    Replies: 15
    Last Post: 28th February 2010, 14:29
  5. twang, wack.........WTF
    By ditchp in forum Vectra C / Signum Car Chat
    Replies: 36
    Last Post: 24th February 2009, 17:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •