User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Engine Management Light

  1. #1
    Regular Member Friel's Avatar
    Join Date
    Feb 2010
    Location
    Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine Management Light

    Hey,

    I'm having serious problems with my Vectra right now. Its an 02 model, 2.0DTI. The car with the spanner through it light has started to come on really really regularly. Now, at the start it would go away when I turned the car off and back on. But it's gradually starting to affect it more and more when I do that now. The car goes into limp mode when it comes on.

    The other night when I turned it off, when I turned it back on the power steering was gone for a good 30 seconds. It then returned completely to normal till the light came back on a few miles later. I turned it off again and the exact same thing happened.

    Then yesterday, the light came on, so I turned the engine off and back on. But the light stayed on, the power steering was gone, and the accelerator wasn't working. The car wouldn't accelerate. When the lights normally on, it still drives, just goes into limp mode. The light went off when I turned it off and back on again, and I managed to drive home as normal.

    This has only started happening so regularly since last week, so I'm kinda hoping I can get abit of advise before I have to spend my money on a mechanic that could end up just giving me the same advice as you guys.

  2. #2
    Regular Member monty2000's Avatar
    Join Date
    Sep 2009
    Location
    swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Pre Face, Colour Coded, CR Tech Box, Pipercross Panel filte, Blanked EGR :-)

    Trim : Club

    Engine : 1.9cdti 16v

    Year : 2005

    Default

    i suggest u get it plugged in mate Tech 2, Opcom etc and see what fault codes your getting

  3. #3
    Regular Member Friel's Avatar
    Join Date
    Feb 2010
    Location
    Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Would a regular mechanic be able to do that? There's not any Vauxhall garages about here that I know of.

  4. #4
    Regular Member
    Join Date
    Jul 2009
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    any local garage should be able to do it for you. Ive had my brake vacuum pump changed cus mine threw up code P0100. This is a default code if the ecu cannot figure out what is wrong. I had EGR, x2 MAF sensors, boost pipes, boost sensor all replaced and still faulted until now. No problems at all

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Replies: 3
    Last Post: 28th April 2009, 19:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •