User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Problem with 2003 Vectra dti

  1. #1
    Regular Member
    Join Date
    Jun 2010
    Location
    N. IRELAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Problem with 2003 Vectra dti

    Hi All

    I drive a 2003 vectra 2.0 dti 100bhp and as past week on the lower gears I am losing power and it’s a lot noiser or has a hum when driving, also bit smokey when taking off..
    And today I found its got worse and is now dangerous to drive…
    Main Vauxhall dealer wants 60 plus vat to plug in it just to find the fault…
    I think it may be the egr valve and have read the section on this but my vectra's egr
    Is different but the one in the tutorial which I think is for the newer cdti models..
    Anyone able to advise me on this thanks

  2. #2
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by molloy View Post
    Hi All

    I drive a 2003 vectra 2.0 dti 100bhp and as past week on the lower gears I am losing power and it’s a lot noiser or has a hum when driving, also bit smokey when taking off..
    And today I found its got worse and is now dangerous to drive…
    Main Vauxhall dealer wants 60 plus vat to plug in it just to find the fault…
    I think it may be the egr valve and have read the section on this but my vectra's egr
    Is different but the one in the tutorial which I think is for the newer cdti models..
    Anyone able to advise me on this thanks

    give egr a clean and boost sensor, do you know how to remove egr?
    also prob worth getting some 10k decoke stuff

    any warning lights on?
    Last edited by chris1804; 24th June 2010 at 14:27.

  3. #3
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    72 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Suer there was a post about doing the EGR on a DTI some where

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  4. #4
    Regular Member
    Join Date
    Jun 2010
    Location
    N. IRELAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi

    yes the yellow car with spanner in it, engine management light i think is on all the time now.. i know how to remove it -there is 2 bolts holding it..

    however i don't know how to clean this one, . i saw the tutorial on the later one which was very good but mine different and can't seem to find the step by step instructions/photos on it

    thanks

  5. #5
    Regular Member dervb's Avatar
    Join Date
    Jun 2007
    Location
    Thornton merseyside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    listen mate, if your taking EGR out do the intake manifold aswell, mine was well cocked up .strangelley enough just on the left side of the EGR valve . that way youdo the boost press sensor aswell only 1/2 days work with cleaning aswell.....good luck.

  6. #6
    Regular Member
    Join Date
    Jun 2010
    Location
    N. IRELAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok but how do you clean these correctly

    do you have to disassemble it and if so how do you go about it?

  7. #7
    Regular Member
    Join Date
    Jan 2010
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : 1.9 cdti

    Engine : 120

    Year : 06

    Default

    Quote Originally Posted by molloy View Post
    Hi All

    I drive a 2003 vectra 2.0 dti 100bhp and as past week on the lower gears I am losing power and it’s a lot noiser or has a hum when driving, also bit smokey when taking off..
    And today I found its got worse and is now dangerous to drive…
    Main Vauxhall dealer wants 60 plus vat to plug in it just to find the fault…
    I think it may be the egr valve and have read the section on this but my vectra's egr
    Is different but the one in the tutorial which I think is for the newer cdti models..
    Anyone able to advise me on this thanks
    Have you check here
    http://www.vectra-c.com/forum/showthread.php?t=60856

    This details the removal and cleaning of 2.0 DTi egr.

  8. #8
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ive got to do my manifold how do u get it off

  9. #9
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by chris1804 View Post
    ive got to do my manifold how do u get it off

    Mate before you remove the EGR for cleaning,have a look at both iintercooler hoses left and right side for ant splits,and also check the rubber joints at the ends of the thin white pipes,they tend to split and this throws up the the spanner light .

  10. #10
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by macdad View Post
    Mate before you remove the EGR for cleaning,have a look at both iintercooler hoses left and right side for ant splits,and also check the rubber joints at the ends of the thin white pipes,they tend to split and this throws up the the spanner light .

    My cars alright I just want to clean manifold just to give it a good clean and see if it runs any better

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra C Y20DTH 2003....is this an ECU problem??
    By Acebob666 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 20th August 2013, 17:22
  2. vectra 1.8 2003 tickover problem....help...
    By gazman in forum Engine & Drivetrain
    Replies: 33
    Last Post: 27th October 2009, 18:19
  3. Problem with vectra-c 2003 dti
    By m15bfe in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 14th April 2009, 17:41
  4. Vauxhall Vectra 2003 2.2 SRI CD problem
    By Gary1985 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 9th January 2009, 23:48
  5. Vectra 2003 V6 3.2 Idle problem
    By joseantoniovalle in forum Introduce yourself.
    Replies: 48
    Last Post: 18th August 2006, 16:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •