User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Is something wrong with my clutch?

  1. #1
    Regular Member
    Join Date
    Jan 2007
    Location
    Chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Is something wrong with my clutch?

    Just took the underside of my dash out, so I could have a look at the clutch pedal mechanism and cruise control switch (my car suffers from the standard clutch return spring problem)

    Round the top of the clutch pedal there is what appears to be a large black spring, which is wrapped around the top where the pedal pivots. Oddly, it just seems to sit there loose, not doing anything at all. Whether the clutch is up, or all the way to the floor, it doesn't seem to do anything at all. The feel end which is in the clutch pedal body just hangs loose and can be moved from side to side.

    What does this spring actually do? Can't tell if there's something wrong with it or not...

  2. #2
    Regular Member old cruiser's Avatar
    Join Date
    Jun 2008
    Location
    slough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Chances are mate it's snapped, this was a common problem and VX do a mod' for this which is a replacement spring that fits onto the pedal arm and it quite easy to fit, there is a how 2 somewhere but can't seem to find it now!!
    Cheers Pete

  3. #3
    Regular Member old cruiser's Avatar
    Join Date
    Jun 2008
    Location
    slough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Here you go mate, just found it!! http://www.vectra-c.com/forum/showthread.php?t=33621
    Cheers Pete

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. clutch pedal really soft after new clutch
    By valvelift in forum Engine & Drivetrain
    Replies: 8
    Last Post: 3rd February 2013, 14:52
  2. Clutch slipping and loosing clutch/brake fluid
    By marty_b0y in forum Engine & Drivetrain
    Replies: 15
    Last Post: 31st May 2012, 00:18
  3. Need help with clutch rattle that dissapears when clutch depressed
    By leeroberts919 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 14th July 2009, 11:56
  4. Wrong place wrong time.
    By silverhairedracer in forum General Chat
    Replies: 6
    Last Post: 29th October 2008, 14:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •