User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Clicking from rear after pad replacement

  1. #1
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default Clicking from rear after pad replacement

    I changed my rear pads recently and have noticed a clicking noise when the wife drives off. I can't hear anything from inside the car and have checked the pads and can't see anything obvious. Any ideas???

  2. #2
    Full Member spennny's Avatar
    Join Date
    Jun 2008
    Location
    Blantyre
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Is there not a stone stuck in the tread ?
    I had this last week after waving the Mrs off in my car

  3. #3
    Regular Member Exclusive BV's Avatar
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    quite common when changing direction (ie from backwards to forwards and vice versa) it could be the pads re-seating themselves.

    Is it only happening under breaking?

  4. #4
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    Quote Originally Posted by spennny View Post
    Is there not a stone stuck in the tread ?
    I had this last week after waving the Mrs off in my car
    sounds too loud for it to be something in the tyre but will check anyway.

    Quote Originally Posted by Exclusive BV View Post
    quite common when changing direction (ie from backwards to forwards and vice versa) it could be the pads re-seating themselves.

    Is it only happening under breaking?
    Happens when driving off without any braking.

  5. #5
    Forum Moderator FIL 4822's Avatar
    Join Date
    Dec 2006
    Location
    On a French Carp lake somewhere x
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia VX-line RED Tourer

    Trim : No, over weight!

    Engine : Flux Core Capacitor

    Year : 1 A.D

    Mileage : Rising

    Default

    Mine did the same when i changed the rears.
    I did the usual tyre checks for stones etc. but found nothing.
    It went away after a couple of days and hasn't come back.


    Have consideration for the deaf, if you're gunna fart, make it smell !


  6. #6
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Are they cheap pads? Ive had this problem before after getting cheap budget pads fitted, not a perfect fit. Replaced them with GM ones and problem solved.

  7. #7
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    Re grease the rears... Mine tapped under braking etc (before biting) after i cleaned them a little too well before painting callipers. Re-greased and nothing since...

  8. #8
    Regular Member John35's Avatar
    Join Date
    Jun 2007
    Location
    in a white box
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had a clicking from my fronts after changing them. Today I took them off and wiggled the offending caliper. Compared to the other side it was fairly loose. The only thing thats stops them moving is the spring so played with that and no more noise. So check the springs are tight.

  9. #9
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    thanks guys, will give them suggestions a go tomorrow.

    PS They are GM ones.

  10. #10
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My rears have done this since K Fit replaced them. I took them back and they fiddled with something that made the noise go away for a few days but it did return. I suspect they fitted pattern brake pads that are not exact size as OEM and this is the cause. It is like the pads are snatching and moving slightly just when the brakes are applied. Only notice the noise at very slow speeds, probably they always do this but the other noises at higher speeds mask it.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rear pad replacement
    By dilan in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 5th January 2011, 19:00
  2. Rear Pad Replacement
    By Fozman in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 12th December 2009, 21:38
  3. rear pad replacement
    By campbell1987 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 6th November 2009, 20:07
  4. Rear Pad replacement
    By phildjohnson in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 12th January 2009, 20:40
  5. Clicking Rear Breaks
    By scottymf in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 3rd August 2008, 17:58

Visitors found this page by searching for:

vectra c estate rear brakes clicking stop when braking

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •