User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Emissions light on after EGR clean.

  1. #1
    Regular Member StarDust2k5's Avatar
    Join Date
    Feb 2010
    Location
    Newport, Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Emissions light on after EGR clean.

    As title says, removed and cleaned out the EGR and now my emissions light is on and it wasent previously. any ideas? got a funny feeling i fudged the EGR when cleaning it.

  2. #2
    Regular Member StarDust2k5's Avatar
    Join Date
    Feb 2010
    Location
    Newport, Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    btw i mad sure all gaskets etc where replaced with a good seal and the valvle itself was opening and closing freely without any soot caught in it.

  3. #3
    Regular Member Hideous's Avatar
    Join Date
    Mar 2007
    Location
    GB
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    what's the mileage on your motor
    i cleaned mine a few times, and it helped for a while -- but at 85,000 miles i got a new one. definitely fixed things for me.
    might be just time for a new one, cleaning doesn't always work.

  4. #4
    Regular Member StarDust2k5's Avatar
    Join Date
    Feb 2010
    Location
    Newport, Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    65k on it now. thing thats got me tho is the light is only on since i cleaned it and had never come on before. also seems to be down on lots of power bellow 2000 rpm and then fine above it since the clean, but it could just be me.

  5. #5
    Regular Member Hideous's Avatar
    Join Date
    Mar 2007
    Location
    GB
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Down on power below 2000rpm is the exact symptom i was having.
    Could be it has seized now, strange that's happened after cleaning it, but you may have dislodged some soot.
    I'd give it one more clean and make sure the mechanism is working while doing so.

  6. #6
    Regular Member StarDust2k5's Avatar
    Join Date
    Feb 2010
    Location
    Newport, Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    yep going to pull it all back off tomorrow and try to figure out whats up with it, hopefully can avoid getting a new one as it would make this a rather expensive mistake as it worked fine before i pulled it all apart.

    guess lesson is if its not broke dont fix it yet again.

  7. #7
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Post Thanks / Like
    Mentioned
    144 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    144 Post(s)
    Tagged
    0 Thread(s)

    Default

    double check the electrical connector... if can look like its on but sometimes doesnt sit right...
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  8. #8
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Hideous View Post
    Could be it has seized now...
    Sounds about right, the light is usually when the EGR is closed, so there's either an electrical issue, or its stuck.

  9. #9
    On a Sabbatical
    Join Date
    Mar 2009
    Location
    caistor
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    so blank it off lol

  10. #10
    Regular Member StarDust2k5's Avatar
    Join Date
    Feb 2010
    Location
    Newport, Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    had taken it for a few spins earlier to try and get the light to go out but nothing. started the car now and took it for a blast up to 120mph down a private road of course and no light.

    still doesnt like to pick up speed from under 2k rpm in anything but 1st and 2nd tho... could just be me noticing it now that im looking for it but never seemed this bad before.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Emissions light
    By iain.condliffe in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 18th April 2013, 10:07
  2. Emissions Light Help!
    By LadOnTractor in forum Engine & Drivetrain
    Replies: 3
    Last Post: 24th July 2011, 08:53
  3. emissions light
    By trickster75 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 19th May 2011, 21:10
  4. Emissions Light
    By BigKev1970 in forum Troubleshooting
    Replies: 6
    Last Post: 7th September 2007, 22:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •