User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Slight Missfire/Judder

  1. #1
    New Member
    Join Date
    Jun 2010
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Slight Missfire/Judder

    Hi all,
    I am new to this site and hope to pick your brains.
    I have just bought a 2005 CDTi 120 with 110k from an auction (I know big mistake!)
    On the drive home I noticed that once the car warmed up it started to feel like it was missfiring or juddering. It drives fine when
    accelerating or cruising at highish revs. It just seems to happen now and again when either I have taken my foot of the accelerator or at low engine speed driving ie 1300-1700rpm. Soon as it happens it stops when I press the accelerate pedal. There are no engine lights on.
    Any ideas on what this could be due to? Anyone had similar problems?
    Cheers for you help.


  2. #2
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    EGR is most likely, just whip it off give it a good clean out wit some parraffin or carb cleaner or the like, get the fiat gaskets for it and refit it, they just coke up inside and cause so many problems its unreal. Would definately be my first port of call anyway, good luck with it matey.

  3. #3
    New Member
    Join Date
    Jun 2010
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers, I'll take a look at a How2 thread and try cleaning it tomorrow.

  4. #4
    New Member
    Join Date
    Jun 2010
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have tried to find a HOW2 but the the one i found seem to have different pictures and I think that they are based on a 150 model.
    Any know if there are any instructions for a 120 model?

  5. #5
    New Member
    Join Date
    Jun 2010
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have managed to get it off.
    It looks fairly claen and the solenoid is loose. I think it may have been changed recently.
    I have also cleaned the boost sensor which was cloged up.
    I cant put it back together untill monday as I didnt get any new gaskets.
    Could my problem be down to anything else?

  6. #6
    Regular Member John35's Avatar
    Join Date
    Jun 2007
    Location
    in a white box
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you have the old gaskets refit and see if it works. There is also a how2 for cleaning the throttle body as well. Defo sounds like a EGR.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slight Judder to 3.0 V6 (54 Plate Facelift)
    By dunc2610 in forum Y & Z30DT Specific
    Replies: 19
    Last Post: 31st May 2013, 08:57
  2. Slight hesitation/judder when accelerating 1.8 petrol
    By waterbourne in forum Engine & Drivetrain
    Replies: 12
    Last Post: 19th January 2011, 00:44
  3. Limited power and slight missfire! Help!!
    By x111pow-signum in forum Engine & Drivetrain
    Replies: 9
    Last Post: 19th October 2010, 19:56
  4. Slight judder
    By Samdy Gray in forum Engine & Drivetrain
    Replies: 6
    Last Post: 20th March 2010, 00:17
  5. Slight engine judder/thud for fraction of a second
    By gekornro in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 3rd April 2008, 21:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •