User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: 2.0 dti cold start problems

  1. #1
    New Member nickp1975's Avatar
    Join Date
    Jun 2010
    Location
    wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 2.0 dti cold start problems

    hi, i have a 2003 vectra c 2.0dti, in the cold weather the car struggles to start, i have replaced the glow plugs and they are working as they should do, and the relay has been changed aswell. the car turns over but it takes a while to catch and there is a huge ploom of smoke. I do also wait for the glow plug light to go off before starting.
    please help as this is very annoying

    nick

  2. #2
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check the leak off pipes from the injectors as they perish and allow air into the fuel system which effectively means you have to completely bleed the system everytime, they're dirt cheap so dont worry too much. If you get stuck pop it over to me and i'll have a look for you.

  3. #3
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)

    Default


    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  4. #4
    New Member nickp1975's Avatar
    Join Date
    Jun 2010
    Location
    wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    hi Dave, i have been told that before, after it's eventually started on the morning it will be fine the rest of the day, even if left for a few hours, do you think it is still the pipes, where r u and how much would u charge to sort the pipes if it is them
    Nick

  5. #5
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    yeah its deffo them pipes if thats the case nick, they only let the tinyiest amount of air in so thats why it takes all night to cause the flow back, its a common issue with the y20dth engine ive done loads of them. I'm only in Cannock and if you want me to do it I'd only charge you for the pipe and you can buy me a pint to do it

  6. #6
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    How old is your battery? We've had a similar problem with our 2.2DTi and after replacing the battery the engine started fine

  7. #7
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Its the leak off pipes, if the battery is good enough to bleed the fuel all the way from the tank to the injectors its not gonna be a knackered battery, the leak off pipes are a common failure on the y20dth engine, grrrrr why do people have to argue when i know what I'm talking about??!!?? I've not been a mechanic for 10 years for nothing you know!!

  8. #8
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    There was no argument in what Celes said, it was mearly a suggestion. There is no need to bite his head off

  9. #9
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    He should have thought about what he said before saying it though really john, if the battery can crank the engine for long enough to completely bleed the fuel system how can it be goosed??? Just really pee's me off when people stick their oar in, its confuses the peeps that aren't clued up on certain things and could cost them money they dont need to spend. I thought we were supposed to help save each other money not cost it each other.

  10. #10
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Look mate, I have simply explained what our problem was. He said "the car turns over but it takes a while to catch and there is a huge ploom of smoke." Our DTi was the same and it turned out to be a weak battery.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cold start problems?
    By Barlow in forum Troubleshooting
    Replies: 7
    Last Post: 24th February 2012, 14:16
  2. 2.2 dti cold start problems
    By MattHD in forum Engine & Drivetrain
    Replies: 4
    Last Post: 20th May 2011, 23:07
  3. 2.0 dti cold start problems
    By nickp1975 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 1st December 2010, 11:33
  4. Cold start problems
    By hippo94735 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 24th February 2010, 19:48
  5. Dti cold start problems
    By storey_3000 in forum Engine & Drivetrain
    Replies: 36
    Last Post: 27th August 2009, 08:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •