User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Vectra-C Elite ( 3.2 V6 ) Engines "dies" and won't start again!

  1. #1
    New Member coombesd's Avatar
    Join Date
    Jun 2010
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Vectra-C Elite ( 3.2 V6 ) Engines "dies" and won't start again!

    Hi, I brought my Vectra Elite a couple of years back and have experienced the cambelt sensor and crankshaft sensor problems....now something else has come along.

    The engine will periodically just die...then when I try to start it again...it just clicks ( reminds me of the sound when you have a dodgy starter motor ) Traction control warning lamp comes on, airbag warning light comes on, car with spanner through it comes on.

    I'm not sure if its temperature related as I only "seem" to get this problem if the temp is past 83 degrees and once the car cools down it seems to start without issue ( so far anyway! ). Has anyone got any ideas on what this could be?....

    Cheers

    Del

  2. #2
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like a crank sensor on its way out to me, when u replaced it last time did you use a genuine one or an aftermarket one?

  3. #3
    New Member coombesd's Avatar
    Join Date
    Jun 2010
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Dave,

    I changed the cam sensor...didn't replace the crank sensor....so is this next on the hitlist do you think?.....I was going to do both at the same time...but there were mixed opinions...some said do both as the other will follow...some advised not to fixed what's not broken....

    Cheers

    Del

  4. #4
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I would change it, but use a genuine part as the after market ones tend to be a bit poo. Sounds like the heat is breaking down the sensor which is why its fine when its cold as nothing has expanded inside the sensor, its a really common problem on lots of cars not just vectra's so dont stress too much that its a vectra thing.

  5. #5
    New Member coombesd's Avatar
    Join Date
    Jun 2010
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers for the advice Dave...will give it a go....

    Del

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra 150 dies on start up :(((
    By Gracey in forum Engine & Drivetrain
    Replies: 8
    Last Post: 26th October 2010, 12:34
  2. Replies: 0
    Last Post: 9th June 2010, 09:19
  3. "Tight" engines
    By Derek Mc in forum Engine & Drivetrain
    Replies: 2
    Last Post: 10th May 2010, 19:51
  4. Internal "cleaning" of engines
    By gtr1000 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 6th November 2009, 10:47

Visitors found this page by searching for:

several cranks from cold to start vectra c 3.2 v6

vectra c engine died and wont re start

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •