User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: 2.2 dti problems.

  1. #1
    On a Sabbatical
    Join Date
    Feb 2009
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2 dti problems.

    Not so much problems but I'm pretty sure my 2.2 dti is pretty sluggish, and when getting to around 3k revs when accelerating hard it develops a tap. Also when pulling off from standing, there is a knock, but this clears after the revs build a little, the engine hardly smokes at all i have had the EGR and Boost valves both out and cleaned, and its just had a full service. Starting to get right on my tits tbh. lol

  2. #2
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    You came from a petrol didn't you, the dti's never gonna be as refined as a petrol mate. (not trying to teach you how to suck eggs though)

    As for the sluggishness try using an additive such as millers eco max. It will clean the fuel system and will quieten the pump down a bit (extra lubrication)

    When was the last time the car was serviced? Have the air filter/ fuel filter been replaced?

  3. #3
    On a Sabbatical
    Join Date
    Feb 2009
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah pal came from a petrol, but only had that roughly 6 weeks, had a diesel focus before that, altho that was one of the quietest diesels I've heard, the tapping comes near enough as soon as it gets too 3k. and the same with the knock when pulling off definitely goes as soon as the revs pick up.

    Was serviced about 3 weeks ago, had Pollen filter, fuel filter, oil filter, and oil, and also had the boost valve out and the egr for cleaning.

    Also every now and then the spanner with car light comes on when start up, but goes as soon as the car revs.

    A mechanic mate of mine suggested maybe Injector seals. Another thing is when turning the ignition lights on, there isnt a light on the dash that indicates the heater plugs warming up, don't you get this on the vectra?

    I just want to get the car right with me getting the coilovers etc on it. want it as close too 100% as I can get it.

  4. #4
    Regular Member AKeeNShoT's Avatar
    Join Date
    May 2009
    Location
    South Shields, T&W
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    generally speaking, my glow plug light only radiates when its cold. warning light on start up, in the little window in the rev counter could be the injectors as it happens, cos my mates used to do that.

  5. #5
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi m8 ive got the same knocking noise on my veccy 2.0 dti and havnt been able to sort it. Its been to different garages and are pretty stumped with it ,giving different bits of advice, guessing mainly. Ive been using millers for about 3 months now. I had injector seals done and it made no difference, had leak off pipes done, no difference. If you find out what the problem is i would love to know as mine has been like it for months.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. z18xer vvti, problems, problems
    By gstore in forum Engine & Drivetrain
    Replies: 15
    Last Post: 20th April 2012, 13:33
  2. 1.8 vvti problems, problems problems!!!
    By gstore in forum Petrol Engine related
    Replies: 8
    Last Post: 3rd March 2012, 01:31
  3. crusie control problems, anyone had similar problems?
    By rozzer2006 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 2nd October 2011, 21:20
  4. GSi problems
    By Piemyster in forum Engine & Drivetrain
    Replies: 22
    Last Post: 27th July 2011, 20:11
  5. 1.9 cdti auto problems problems
    By trigger in forum Engine & Drivetrain
    Replies: 2
    Last Post: 28th September 2009, 17:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •